summaryrefslogtreecommitdiff
path: root/src/abslibre-tools/librestage
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-05-24 15:17:59 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-05-24 16:24:13 -0400
commit05128d533225b75f35f79a1f55b04556b7e9736b (patch)
treea2e8d723e76fd8e44c81ea0fbe1ad4dda597856d /src/abslibre-tools/librestage
parentd712e575c0d5b1bf66443beec3e7ed75be636e2d (diff)
Merge conf.sh:load_files and conf.sh:check_vars into load_conf
Diffstat (limited to 'src/abslibre-tools/librestage')
-rwxr-xr-xsrc/abslibre-tools/librestage10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/abslibre-tools/librestage b/src/abslibre-tools/librestage
index 74de8fb..0794b13 100755
--- a/src/abslibre-tools/librestage
+++ b/src/abslibre-tools/librestage
@@ -60,10 +60,12 @@ main() {
fi
# Load configuration
- load_files libretools
- check_vars libretools WORKDIR || return 1
- load_files makepkg # for PKGDEST, SRCDEST, and SRCPKGDEST, which are optional
- load_files librefetch # for MIRRORS, which is optional
+ declare -i ret=0
+ load_conf libretools.conf WORKDIR || ret=$?
+ load_conf makepkg.conf || ret=$? # for PKGDEST, SRCDEST, and SRCPKGDEST, which are optional
+ load_conf librefetch.conf || ret=$? # for MIRRORS, which is optional
+ [[ $ret = 0 ]] || exit $ret
+
SRCPKGPOOL="$WORKDIR/staging/sources/parabola"
# Load the PKGBUILD