summaryrefslogtreecommitdiff
path: root/src/abslibre-tools
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
commit7e704d7ac997387341e920e1757c24cac0efe5e9 (patch)
treea9f30eabaaad5496397a91053d3e03bab1ea57e4 /src/abslibre-tools
parent7785a72495e3eb0ea826b41720c241f58a15b601 (diff)
Refactor the build system. Avoid recursive make.
This looks like a lot, but more things should "just work". We have `make dist` now!
Diffstat (limited to 'src/abslibre-tools')
-rw-r--r--src/abslibre-tools/Makefile5
-rw-r--r--src/abslibre-tools/createworkdir.md36
2 files changed, 40 insertions, 1 deletions
diff --git a/src/abslibre-tools/Makefile b/src/abslibre-tools/Makefile
index 2c76089..2903f4a 100644
--- a/src/abslibre-tools/Makefile
+++ b/src/abslibre-tools/Makefile
@@ -1 +1,4 @@
-include ../../common.mk
+include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
+include $(topsrcdir)/automake.head.mk
+
+include $(topsrcdir)/automake.tail.mk
diff --git a/src/abslibre-tools/createworkdir.md b/src/abslibre-tools/createworkdir.md
new file mode 100644
index 0000000..e50b00f
--- /dev/null
+++ b/src/abslibre-tools/createworkdir.md
@@ -0,0 +1,36 @@
+# CreateWorkDir
+
+This script recreates a proper directory tree for packaging. Its aim is to help
+you be organized with the work you do as a packager, and establish a certain
+standard for packages' publication, so you don't have to lose much time with
+them. Just package and upload!
+
+It will create a directory tree like this:
+
+ $WORKDIR/
+ ├── abslibre/
+ │ ├── .git/
+ │ ├── libre/<PKGBUILDS>
+ │ └── libre-testing/<PKGBUILDS>
+ └── staging/
+ ├── libre/
+ └── libre-testing/
+
+*Related Variables*
+ - WORKDIR
+
+## staging/
+
+This directory contains one directory for each repository, where the resulting
+packages are in moved for syncing against the main repository on Parabola's
+server. This directory is architecture independent.
+
+## abslibre/
+
+This is the git repo for Parabola's PKGBUILDs. Here you can find the ABS tree
+for our packages, and also where you'll have to put new ones for commit.
+
+(You'll need push access to Parabola's main server, but pulling is public.)
+
+*Related Variables*
+ - ABSLIBREGIT