summaryrefslogtreecommitdiff
path: root/src/aur
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-04-20 21:50:58 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-04-20 22:56:14 -0400
commitd958a33c1f0e11b770481a9188cbf75cc3bfd0a5 (patch)
treeb5ae47096365863eb26a77a89af0e36b48b5ca03 /src/aur
parent2d1ae58285ade402260bf5d5a4dbf42aba027fc5 (diff)
Quote unquoted strings that should probably be quoted.
These were found with the help of shellcheck. Nothing more complicated than wrapping a variable in double quotes has been done.
Diffstat (limited to 'src/aur')
-rwxr-xr-xsrc/aur8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/aur b/src/aur
index 84dc984..f904a16 100755
--- a/src/aur
+++ b/src/aur
@@ -1,7 +1,7 @@
#!/usr/bin/env bash
# Copyright (C) 2010-2011 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
# Copyright (C) 2010-2012 Nicolás Reynolds <fauno@parabola.nu>
-# Copyright (C) 2012-2014 Luke Shumaker <lukeshu@sbcglobal.net>
+# Copyright (C) 2012-2014, 2017 Luke Shumaker <lukeshu@sbcglobal.net>
#
# License: GNU GPLv3+
#
@@ -66,7 +66,7 @@ main() {
# Store our copy of the PKGBUILD dir
copy_old=$copy_new
- copy_new="$(mktemp --tmpdir -d aur-${pkg}.new.XXXX)/$pkg"
+ copy_new="$(mktemp --tmpdir -d "aur-${pkg}.new.XXXX")/$pkg"
cd "${copy_new%/*}"
fi
@@ -123,10 +123,10 @@ main() {
msg2 "Checking dependencies"
for _dep in "${_deps[@]}"; do
_dep=${_dep/[<>=]*/}
- if ! is_built $_dep; then
+ if ! is_built "$_dep"; then
if ! pacman -Sddp "$_dep" &>/dev/null ; then
plain "%s: will be downloaded from AUR" "$_dep"
- missing_deps+=($_dep)
+ missing_deps+=("$_dep")
fi
else
plain "%s: is on repos" "$_dep"