summaryrefslogtreecommitdiff
path: root/src/aur
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-10-26 01:35:45 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-10-26 17:18:11 -0400
commit23faa9361d79d1d88754a1e1e5aa9f040b34545c (patch)
tree2a0dcd569de702c6f697c5e5536c5ddd07c8146e /src/aur
parent99933725329dc760f5cc704b3fd20f033dafdd14 (diff)
Merge pkgbuild-check-{nonfree,licenses}, add a summarize tool for it.
This should fix a number of bugs in those two scripts, and the summarize script simplifies aur and libremakepkg:hooks-check.sh
Diffstat (limited to 'src/aur')
-rwxr-xr-xsrc/aur21
1 files changed, 1 insertions, 20 deletions
diff --git a/src/aur b/src/aur
index 2c1fe6d..6fce891 100755
--- a/src/aur
+++ b/src/aur
@@ -107,26 +107,7 @@ main() {
################################################################
pkgbuild-check-nonfree -c
- case $? in
- 0) :;;
- 15) warning "This PKGBUILD links to known unfree packages";;
- *) warning "pkgbuild-check-nonfree failed to run";;
- esac
-
- ################################################################
-
- local s=0
- pkgbuild-check-licenses || s=$?
- for i in 1 2 4; do
- if [[ $i -eq $(($s & $i)) ]]; then
- case $i in
- 1) warning "pkgbuild-check-licenses encountered an error";;
- 2) warning "This PKGBUILD has an uncommon license";;
- 4) warning "This PKGBUILD has a known nonfree license";;
- esac
- fi
- done
- unset s
+ pkgbuild-summarize-nonfree $?
################################################################