summaryrefslogtreecommitdiff
path: root/src/aur
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:36:55 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 20:01:07 -0600
commitbeae9b3e2822021fea741fc98282cf9e0fc1d024 (patch)
treeab2c55df74fb068050be1f293b9a9df24721f24f /src/aur
parent1d6066b37e0fd4e7118a3d366d1b6a2168a70286 (diff)
Double bracket ==/</> compare lexicographically, not numerically.
Unfortunately for me, that means that it works correctly *most* of the time. But, for example, [[ 10 < 2 ]], and negatives don't work.
Diffstat (limited to 'src/aur')
-rwxr-xr-xsrc/aur2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/aur b/src/aur
index a09c923..86b93e6 100755
--- a/src/aur
+++ b/src/aur
@@ -103,7 +103,7 @@ main() {
local s=0
pkgbuild-check-licenses || s=$?
for i in 1 2 4; do
- if [[ $s == $(($s & $i)) ]]; then
+ if [[ $s -eq $(($s & $i)) ]]; then
case $i in
1) warning "pkgbuild-check-licenses encountered an error";;
2) warning "This PKGBUILD has an uncommon license";;