summaryrefslogtreecommitdiff
path: root/src/chroot-tools/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-08-25 14:18:14 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-11 15:43:30 -0400
commitf3030244f64699021ec0d9cd9e4b4d67244d9df1 (patch)
tree2a2ed877b15799cbc33111528e286e6796c45e78 /src/chroot-tools/Makefile
parentdabf1a9cf520d725f8eb767bb0112990f99fde05 (diff)
Make common-devtools.mk unnecessary. Move devtools chroot stuff into chroot-tools
Diffstat (limited to 'src/chroot-tools/Makefile')
-rw-r--r--src/chroot-tools/Makefile34
1 files changed, 32 insertions, 2 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 27030e3..7f6a7ea 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -1,3 +1,33 @@
-libre_execdir=$(sbindir)
-libre_confdir=$(sysconfdir)/libretools.d
+# The makechrootpkg flow is:
+# $(devtoolsdir)/*.in -> *.sh.in + *.sh.patch -> *.sh.ugly -> *.sh
+
+copy_files = makechrootpkg.sh.in archroot.in
+libs = makechrootpkg.sh
+progs = archroot
+clean_files = makechrootpkg.sh.ugly* *~
include ../../common.mk
+
+# Copy ###############################################################
+
+makechrootpkg.sh.in: %.sh.in: $(devtoolsdir)/%.in
+ cp $< $@
+
+archroot.in: $(devtoolsdir)/mkarchroot.in
+ cp $< $@
+
+# Build ##############################################################
+
+makechrootpkg.sh.ugly: %.ugly: %.in %.patch Makefile
+ @echo "GEN $@"
+ @cp $*.in $@
+ @patch $@ $*.patch || { rm -f -- '$@'; false; }
+
+makechrootpkg.sh: %: %.ugly Makefile
+ @echo "GEN $@"
+ @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
+ $(call indent,$@) || { rm -f -- '$@'; false; }
+
+archroot: %: %.in Makefile
+ @echo "GEN $@"
+ @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
+ @chmod 755 "$@" || { rm -f -- '$@'; false; }