summaryrefslogtreecommitdiff
path: root/src/chroot-tools/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-02-15 18:55:25 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2017-04-11 13:02:27 -0400
commit74067d389c204cd40906980391680724380667c0 (patch)
tree654f7aaed07e8fe019893337256929db87a017a1 /src/chroot-tools/Makefile
parent2e798795833af72ba0618f5577f15488b201b0fa (diff)
Expect devtools files to already be patched.
Diffstat (limited to 'src/chroot-tools/Makefile')
-rw-r--r--src/chroot-tools/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 93655d7..055b40e 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -3,14 +3,14 @@ include $(topsrcdir)/build-aux/Makefile.head.mk
pkglibexecdir = $(libexecdir)/libretools/chroot
-libretools.src.devtools = makechrootpkg.sh.in mkarchroot.in arch-nspawn.in
+libretools.src.devtools = makechrootpkg.in mkarchroot.in arch-nspawn.in
libretools.out.bins = chcleanup librechroot libremakepkg
libretools.out.libexecs = arch-nspawn chcleanup distcc-tool indent mkarchroot
libretools.out.libs = $(libretools.src.sh) makechrootpkg.sh
files.out.int += chcleanup.lib
-$(srcdir)/makechrootpkg.sh.in: $(srcdir)/%.sh.in: $(devtoolsdir)/%.in
- cp $< $@
+$(srcdir)/makechrootpkg.sh.in: $(srcdir)/makechrootpkg.in
+ sed '/^\s*main "$$@"\s*$$/d' < $< > $@
$(outdir)/chcleanup: $(srcdir)/chcleanup.in $(outdir)/chcleanup.lib
m4 -I$(@D) -P $< | $(libretools.edit) | install -m755 /dev/stdin $@