summaryrefslogtreecommitdiff
path: root/src/chroot-tools/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-06-09 15:55:33 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-06-09 15:55:33 -0400
commitd330445fb7f84748e70e67ca5bc44ce0a1a258f7 (patch)
tree0c1c957298635b7ba0ff69c2fe76af647304a631 /src/chroot-tools/Makefile
parentf579b669d45c02b39474827f12522ff4afa6cf4a (diff)
Work with the new version of autothing.
Diffstat (limited to 'src/chroot-tools/Makefile')
-rw-r--r--src/chroot-tools/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 48a1631..96fb837 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -1,19 +1,19 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
-include $(topsrcdir)/automake.head.mk
+include $(topsrcdir)/build-aux/Makefile.head.mk
pkglibexecdir = $(libexecdir)/libretools/chroot
libretools-bins = chcleanup librechroot libremakepkg
libretools-libexecs += arch-nspawn chcleanup distcc-tool indent mkarchroot
libretools-libs += makechrootpkg.sh
devtools-files = makechrootpkg.sh.in mkarchroot.in arch-nspawn.in
-am_clean_files += chcleanup.lib
+std.clean_files += chcleanup.lib
$(srcdir)/makechrootpkg.sh.in: $(srcdir)/%.sh.in: $(devtoolsdir)/%.in
cp $< $@
$(outdir)/chcleanup: $(srcdir)/chcleanup.in $(outdir)/chcleanup.lib
m4 -I$(@D) -P $< | $(edit) | install -m755 /dev/stdin $@
-$(outdir)/chcleanup.lib: $(call _am_path,$(topoutdir)/src/lib/common.sh) $(outdir)/Makefile
+$(outdir)/chcleanup.lib: $(call at.path,$(topoutdir)/src/lib/common.sh) $(outdir)/Makefile
bash -c '. $<; declare -f _l plain msg msg2 error' > $@
$(outdir)/distcc-tool.pot: LIBREXGETTEXT_FLAGS+=--simple=errusage
@@ -22,6 +22,6 @@ $(DESTDIR)$(bindir)/chcleanup: $(var)bindir $(var)libexecdir
mkdir -p $(@D)
ln -srfT $(DESTDIR)$(libexecdir)/libretools/chroot/chcleanup $@
-am_depdirs = ../lib
+at.depdirs += ../lib
-include $(topsrcdir)/automake.tail.mk
+include $(topsrcdir)/build-aux/Makefile.tail.mk