summaryrefslogtreecommitdiff
path: root/src/chroot-tools/libremakepkg
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2021-01-22 20:32:35 -0500
committerbill-auger <mr.j.spam.me@gmail.com>2021-01-22 20:32:35 -0500
commit2926a8703fa6cedd409d76f6fb6b90e193b926de (patch)
tree06f578a29efe4d6ff1d54948cf693c3dcbc72c89 /src/chroot-tools/libremakepkg
parentd0a14f1b7765911fca4578b72f5023672bfde234 (diff)
housekeeping
Diffstat (limited to 'src/chroot-tools/libremakepkg')
-rwxr-xr-xsrc/chroot-tools/libremakepkg10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/chroot-tools/libremakepkg b/src/chroot-tools/libremakepkg
index 80d7444..93f5dfc 100755
--- a/src/chroot-tools/libremakepkg
+++ b/src/chroot-tools/libremakepkg
@@ -261,8 +261,7 @@ main() {
fi
else
if [[ ! -f PKGBUILD ]]; then
- # This is the message used by makepkg
- error "PKGBUILD does not exist."
+ error "No PKGBUILD exists in the present directory."
exit $EXIT_FAILURE
fi
fi
@@ -302,17 +301,18 @@ main() {
msg 'Using existing source package %s' "$srcpkg"
# TODO: symlink $srcpkg to ${SRCPKGDEST}/${pkgbase}-${evr}-${CARCH}${SRCEXT}
else
- msg 'Downloading sources...'
- local srcpkgdest
- srcpkgdest="$(mktemp -d)"
+ local srcpkgdest="$(mktemp -d)"
chown "$LIBREUSER:" "$srcpkgdest"
trap "rm -rf -- ${srcpkgdest@Q}" EXIT
+
+ msg 'Downloading sources...'
SRCPKGDEST="$srcpkgdest" download_sources "$copydir" "$LIBREUSER" |& indent
srcpkg=("$srcpkgdest"/*)
if (( ${#srcpkg[@]} != 1 )); then
error 'Something went funny with makepkg --allsource'
return $EXIT_FAILURE
fi
+
# We want to inject "-$pkgarch" in to srcpkg's filename, right before $SRCEXT
local srcext pkgarch srcpkg_filename
srcext="$(MAKEPKG_CONF=$copydir/etc/makepkg.conf get_var makepkg SRCEXT)"