summaryrefslogtreecommitdiff
path: root/src/chroot-tools/makechrootpkg.sh.patch
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-03-21 14:39:06 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-03-21 14:39:06 -0400
commitd25f30f25ce61367c81133c9cd01fe3169d8f6c0 (patch)
treee1210c8d234b1728556055831c826b889d432d5b /src/chroot-tools/makechrootpkg.sh.patch
parentada82c54e5948ae6353d7024151dcc429665a070 (diff)
Do an audit of copyright and license claims
Diffstat (limited to 'src/chroot-tools/makechrootpkg.sh.patch')
-rw-r--r--src/chroot-tools/makechrootpkg.sh.patch45
1 files changed, 26 insertions, 19 deletions
diff --git a/src/chroot-tools/makechrootpkg.sh.patch b/src/chroot-tools/makechrootpkg.sh.patch
index 540e6ba..de57aeb 100644
--- a/src/chroot-tools/makechrootpkg.sh.patch
+++ b/src/chroot-tools/makechrootpkg.sh.patch
@@ -1,6 +1,13 @@
---- makechrootpkg.sh.in 2014-01-05 18:51:41.463720929 -0500
-+++ makechrootpkg.sh.ugly 2014-02-09 20:20:25.021630727 -0500
-@@ -12,6 +12,7 @@
+--- makechrootpkg.sh.in 2014-03-21 13:59:31.239683366 -0400
++++ makechrootpkg.sh.ugly 2014-03-21 14:19:20.747789508 -0400
+@@ -1,4 +1,6 @@
+ #!/bin/bash
++# License: GNU GPLv2
++#
+ # This program is free software; you can redistribute it and/or modify
+ # it under the terms of the GNU General Public License as published by
+ # the Free Software Foundation; version 2 of the License.
+@@ -12,6 +14,7 @@
shopt -s nullglob
@@ -8,7 +15,7 @@
_makepkg_args=(-s --noconfirm -L --holdver)
makepkg_args=("${_makepkg_args[@]}")
repack=false
-@@ -29,9 +30,10 @@
+@@ -29,9 +32,10 @@
bindmounts_rw=()
copy=$USER
@@ -20,7 +27,7 @@
usage() {
echo "Usage: ${0##*/} [options] -r <chrootdir> [--] [makepkg args]"
-@@ -67,6 +69,7 @@
+@@ -67,6 +71,7 @@
exit 1
}
@@ -28,7 +35,7 @@
while getopts 'hcur:I:l:nTD:d:' arg; do
case "$arg" in
h) usage ;;
-@@ -93,9 +96,6 @@
+@@ -93,9 +98,6 @@
[[ ! -d $chrootdir ]] && die "No chroot dir defined, or invalid path '%s'" "$passeddir"
[[ ! -d $chrootdir/root ]] && die "Missing chroot dir root directory. Try using: mkarchroot %s/root base-devel" "$chrootdir"
@@ -38,7 +45,7 @@
if [[ ${copy:0:1} = / ]]; then
copydir=$copy
else
-@@ -115,30 +115,48 @@
+@@ -115,30 +117,48 @@
esac
done
@@ -93,7 +100,7 @@
# Get a read lock on the root chroot to make
# sure we don't clone a half-updated chroot
slock 8 "$chrootdir/root.lock" "Locking clean chroot"
-@@ -159,11 +177,16 @@
+@@ -159,11 +179,16 @@
# Drop the read lock again
lock_close 8
@@ -113,7 +120,7 @@
if [[ "$chroottype" == btrfs ]] && ! mountpoint -q "$copydir"; then
btrfs subvolume delete "$copydir" >/dev/null ||
die "Unable to delete subvolume %s" "$copydir"
-@@ -178,9 +201,14 @@
+@@ -178,9 +203,14 @@
stat_done
}
@@ -128,7 +135,7 @@
for install_pkg in "${install_pkgs[@]}"; do
pkgname="${install_pkg##*/}"
cp "$install_pkg" "$copydir/$pkgname"
-@@ -193,11 +221,19 @@
+@@ -193,11 +223,19 @@
rm "$copydir/$pkgname"
done
@@ -150,7 +157,7 @@
$repack || rm -rf "$copydir/build"
mkdir -p "$copydir/build"
-@@ -236,12 +272,12 @@
+@@ -236,12 +274,12 @@
chown -R nobody "$copydir"/{build,pkgdest,srcpkgdest,logdest,srcdest,startdir}
@@ -165,7 +172,7 @@
sed -i '/^PACKAGER=/d' "$copydir/etc/makepkg.conf"
echo "PACKAGER='${PACKAGER}'" >> "$copydir/etc/makepkg.conf"
fi
-@@ -254,20 +290,38 @@
+@@ -254,20 +292,38 @@
chmod 440 "$copydir/etc/sudoers.d/nobody-pacman"
fi
@@ -206,7 +213,7 @@
makepkg --config="$copydir/etc/makepkg.conf" --verifysource -o
else
( export SRCDEST BUILDDIR="$builddir"
-@@ -277,10 +331,10 @@
+@@ -277,10 +333,10 @@
(( $? != 0 )) && die "Could not download sources."
# Clean up garbage from verifysource
@@ -219,7 +226,7 @@
# This function isn't run in makechrootpkg,
# so no global variables
local run_namcap="$1"; shift
-@@ -291,6 +345,7 @@
+@@ -291,6 +347,7 @@
shopt -s nullglob
# XXX: Workaround makepkg disliking read-only dirs
@@ -227,7 +234,7 @@
ln -sft /srcdest /srcdest_host/*
ln -sft /startdir /startdir_host/*
-@@ -316,11 +371,29 @@
+@@ -316,11 +373,29 @@
# Safety check
if [[ ! -w PKGBUILD ]]; then
@@ -258,7 +265,7 @@
if $run_namcap; then
pacman -S --needed --noconfirm namcap
-@@ -333,12 +406,24 @@
+@@ -333,12 +408,24 @@
exit 0
}
@@ -283,7 +290,7 @@
for l in "$copydir"/logdest/*; do
[[ $l == */logpipe.* ]] && continue
chown "$src_owner" "$l"
-@@ -352,6 +437,10 @@
+@@ -352,6 +439,10 @@
}
# }}}
@@ -294,7 +301,7 @@
umask 0022
load_vars /etc/makepkg.conf
-@@ -363,30 +452,45 @@
+@@ -363,30 +454,45 @@
[[ -d $SRCPKGDEST ]] || SRCPKGDEST=$PWD
[[ -d $LOGDEST ]] || LOGDEST=$PWD
@@ -346,7 +353,7 @@
if (( ret != 0 )); then
if $temp_chroot; then
-@@ -397,3 +501,4 @@
+@@ -397,3 +503,4 @@
else
true
fi