summaryrefslogtreecommitdiff
path: root/src/chroot-tools
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-10-04 16:30:10 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-10-04 16:30:10 -0400
commit4684fbbae4cd7b8f6d068ce9996b7759ca42e86c (patch)
tree2a98580947ff400dc70161f00b9f77497af92d15 /src/chroot-tools
parent93240c2568e50f43d2854efce97a31deb198b611 (diff)
librechroot/hook-chcleanup: look at /startdir/PKGBUILD, not /build/PKGBUILD
Diffstat (limited to 'src/chroot-tools')
-rw-r--r--src/chroot-tools/hooks-chcleanup.sh2
-rwxr-xr-xsrc/chroot-tools/librechroot8
2 files changed, 5 insertions, 5 deletions
diff --git a/src/chroot-tools/hooks-chcleanup.sh b/src/chroot-tools/hooks-chcleanup.sh
index 198bc36..3c91c35 100644
--- a/src/chroot-tools/hooks-chcleanup.sh
+++ b/src/chroot-tools/hooks-chcleanup.sh
@@ -7,7 +7,7 @@ clean_chroot() (
set +x
local copydir=$1
if $INCHROOT; then
- cd /build
+ cd /startdir
sudo -u nobody "$(librelib chroot/chcleanup)"
else
librechroot "${librechroot_flags[@]}" clean-pkgs
diff --git a/src/chroot-tools/librechroot b/src/chroot-tools/librechroot
index cb7fe1b..bebc46f 100755
--- a/src/chroot-tools/librechroot
+++ b/src/chroot-tools/librechroot
@@ -136,8 +136,8 @@ usage() {
flag 'update' 'Like `pacman -Syu`'
flag 'clean-pkgs' 'Remove all packages from the chroot copy that
are not in base-devel, $CHROOTEXTRAPKG, or named
- as a dependency in the file `/build/PKGBUILD` in
- the chroot copy'
+ as a dependency in the file `/startdir/PKGBUILD`
+ in the chroot copy'
print ' Other:'
flag "run $(_ CMD...)" 'Run CMD in the chroot copy'
flag 'enter' 'Enter an interactive shell in the chroot copy'
@@ -300,8 +300,8 @@ main() {
install -m755 "$(librelib chroot/chcleanup)" "$copydir/bin/chcleanup"
printf '%s\n' \
'#!/bin/bash' \
- 'mkdir -p /build' \
- 'cd /build' \
+ 'mkdir -p /startdir' \
+ 'cd /startdir' \
'/bin/chcleanup' \
> "$copydir/chrootexec"
chmod 755 "$copydir/chrootexec"