summaryrefslogtreecommitdiff
path: root/src/chroot-tools
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-03-24 14:52:04 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-03-24 19:21:54 -0400
commit59d6e4cabc9490ea3a9c876924059bf8a0428e17 (patch)
tree7399013e99e6e3924234b49239e3e2e9742d6b55 /src/chroot-tools
parentdf7ede3ffcd8cdfc39d0cba4d6ae18a7fd78ed9e (diff)
Makefile: Support split libdir / libexecdir
I intend to have xbs-abs have separate libdir / libexecdir s.
Diffstat (limited to 'src/chroot-tools')
-rw-r--r--src/chroot-tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index e3274e0..412ebb5 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -2,12 +2,14 @@ include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
pkglibexecdir = $(libexecdir)/libretools/chroot
+pkglibdir = $(libdir)/libretools/chroot
libretools.src.devtools = makechrootpkg.in mkarchroot.in arch-nspawn.in
-libretools.out.bins = chcleanup librechroot libremakepkg
+libretools.out.bins = librechroot libremakepkg
libretools.out.libexecs = arch-nspawn chcleanup distcc-tool indent mkarchroot
libretools.out.libs = $(libretools.src.sh) makechrootpkg.sh
files.out.int += chcleanup.lib
+files.sys.all += $(bindir)/chcleanup # not in libretools.out.bins because explicit rule
$(srcdir)/makechrootpkg.sh.in: $(srcdir)/makechrootpkg.in
sed -e '1s^.*^#!/hint/bash -euE^' -e '/^\s*main "$$@"\s*$$/d' < $< > $@