summaryrefslogtreecommitdiff
path: root/src/devtools/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
commit7e704d7ac997387341e920e1757c24cac0efe5e9 (patch)
treea9f30eabaaad5496397a91053d3e03bab1ea57e4 /src/devtools/Makefile
parent7785a72495e3eb0ea826b41720c241f58a15b601 (diff)
Refactor the build system. Avoid recursive make.
This looks like a lot, but more things should "just work". We have `make dist` now!
Diffstat (limited to 'src/devtools/Makefile')
-rw-r--r--src/devtools/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 3fc5d70..7ccbbcc 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -1,8 +1,12 @@
-progs = checkpkg find-libdeps finddeps lddd
-copy_files = $(addsuffix .in,$(progs))
-install_files = $(DESTDIR)$(bindir)/find-libprovides
-include ../../common.mk
+include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
+include $(topsrcdir)/automake.head.mk
+
+install-bins += checkpkg find-libdeps finddeps lddd
+devtools-files = $(addsuffix .in,$(install-bins))
+am_sys_files += $(bindir)/find-libprovides
$(DESTDIR)$(bindir)/find-libprovides:
install -d $(@D)
ln -sf find-libdeps $@
+
+include $(topsrcdir)/automake.tail.mk