summaryrefslogtreecommitdiff
path: root/src/devtools/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-27 09:55:16 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-05-27 09:55:16 -0400
commit3c306f6b22883f8462efa26315770fdfc7369964 (patch)
tree5b79fa78e578df55e0f701ea702842e689b971ea /src/devtools/Makefile
parent2ad4125443fbccf5e3c955f14dd2dd9c463b2557 (diff)
flesh out the header added to common.sh
Diffstat (limited to 'src/devtools/Makefile')
-rw-r--r--src/devtools/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 18f1518..e0a7386 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -16,7 +16,7 @@ sysconfdir=/etc
docdir=$(datarootdir)/doc
-################################################################################
+######################################################################
pkglibexecdir=$(libexecdir)/libretools
@@ -67,14 +67,13 @@ indent = emacs --batch $1 \
@$(edit) <"$<" >"$@"
@chmod 755 "$@"
-lib/common.sh: %: %.in Makefile
+lib/common.sh: %: %.in %.top Makefile
@echo "GEN $@"
@{ \
- echo '#!/bin/bash -euE' && \
- echo '#!/bin/bash' && \
+ cat "$*.top" && \
echo 'if [[ -z $${_INCLUDE_COMMON_SH:-} ]]; then' && \
echo '_INCLUDE_COMMON_SH=true' && \
- cat "$<" && \
+ cat "$*.in" && \
echo 'fi'; } > "$@"
lib/makechrootpkg.sh.ugly: %.ugly: %.in %.patch Makefile