summaryrefslogtreecommitdiff
path: root/src/devtools/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-08-25 14:18:14 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-11 15:43:30 -0400
commitf3030244f64699021ec0d9cd9e4b4d67244d9df1 (patch)
tree2a2ed877b15799cbc33111528e286e6796c45e78 /src/devtools/Makefile
parentdabf1a9cf520d725f8eb767bb0112990f99fde05 (diff)
Make common-devtools.mk unnecessary. Move devtools chroot stuff into chroot-tools
Diffstat (limited to 'src/devtools/Makefile')
-rw-r--r--src/devtools/Makefile76
1 files changed, 8 insertions, 68 deletions
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index bca9780..6cae230 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -1,76 +1,16 @@
-topdir = ../..
-include ../../common-devtools.mk
+progs = checkpkg find-libdeps finddeps lddd
+copy_files = $(addsuffix .in,$(progs))
+install_files = $(DESTDIR)$(bindir)/find-libprovides
+include ../../common.mk
-######################################################################
-
-pkglibexecdir=$(libexecdir)/libretools
-
-######################################################################
-
-copy: \
- archroot.in \
- checkpkg.in \
- find-libdeps.in \
- finddeps.in \
- lddd.in \
- lib/makechrootpkg.sh.in
-
-archroot.in: $(devtoolsdir)/mkarchroot.in ; cp $< $@
-checkpkg.in: $(devtoolsdir)/checkpkg.in ; cp $< $@
-find-libdeps.in: $(devtoolsdir)/find-libdeps.in ; cp $< $@
-finddeps.in: $(devtoolsdir)/finddeps.in ; cp $< $@
-lddd.in: $(devtoolsdir)/lddd.in ; cp $< $@
-lib/makechrootpkg.sh.in: $(devtoolsdir)/makechrootpkg.in ; cp $< $@
-
-######################################################################
-
-build: \
- archroot \
- checkpkg \
- find-libdeps \
- finddeps \
- lddd \
- lib/makechrootpkg.sh
-
-indent = emacs --batch $1 \
- --eval '(setq sh-basic-offset 8)' \
- --eval '(indent-region (point-min) (point-max) nil)' \
- -f save-buffer &>/dev/null
+# Build ##############################################################
%: %.in Makefile
@echo "GEN $@"
- @$(edit) <"$<" >"$@"
- @chmod 755 "$@"
-
-lib/makechrootpkg.sh.ugly: %.ugly: %.in %.patch Makefile
- @echo "GEN $@"
- @cp $*.in $@
- @patch $@ $*.patch
-
-lib/makechrootpkg.sh: %: %.ugly Makefile
- @echo "GEN $@"
- @$(edit) <"$<" >"$@"
- $(call indent,$@)
-
-######################################################################
-
-install: \
- $(DESTDIR)$(sbindir)/archroot \
- $(DESTDIR)$(bindir)/checkpkg \
- $(DESTDIR)$(bindir)/find-libdeps \
- $(DESTDIR)$(bindir)/find-libprovides \
- $(DESTDIR)$(bindir)/finddeps \
- $(DESTDIR)$(bindir)/lddd \
- $(DESTDIR)$(pkglibexecdir)/makechrootpkg.sh
-
-$(DESTDIR)$(sbindir)/%: %
- install -Dm755 $< $@
-
-$(DESTDIR)$(bindir)/%: %
- install -Dm755 $< $@
+ @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
+ @chmod 755 "$@" || { rm -f -- '$@'; false; }
-$(DESTDIR)$(pkglibexecdir)/%: lib/%
- install -Dm644 $< $@
+# Install ############################################################
$(DESTDIR)$(bindir)/find-libprovides:
install -d $(@D)