summaryrefslogtreecommitdiff
path: root/src/devtools/finddeps.in
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-01-17 21:14:02 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-01-17 21:14:02 -0500
commitc79e6971d56c347cee39fe2e601226865ac2ae1e (patch)
tree4e26187f01ac14e9f23b89b9eb70dc92f35eb952 /src/devtools/finddeps.in
parent5c2dd97a91421e6e5f7e920579fcb88bb71e7fa7 (diff)
parent512436524cd3e70b9394d304bc9a43c6858c3695 (diff)
Merge commit '512436524cd3e70b9394d304bc9a43c6858c3695' as 'src/devtools'
Diffstat (limited to 'src/devtools/finddeps.in')
-rw-r--r--src/devtools/finddeps.in39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/devtools/finddeps.in b/src/devtools/finddeps.in
new file mode 100644
index 0000000..656fe5a
--- /dev/null
+++ b/src/devtools/finddeps.in
@@ -0,0 +1,39 @@
+#!/bin/bash
+#
+# finddeps - find packages that depend on a given depname
+#
+
+source @pkgdatadir@/common.sh
+
+match=$1
+
+if [[ -z $match ]]; then
+ echo 'Usage: finddeps <depname>'
+ echo ''
+ echo 'Find packages that depend on a given depname.'
+ echo 'Run this script from the top-level directory of your ABS tree.'
+ echo ''
+ exit 1
+fi
+
+find . -type d | while read d; do
+ if [[ -f "$d/PKGBUILD" ]]; then
+ unset pkgname depends makedepends optdepends
+ . "$d/PKGBUILD"
+ for dep in "${depends[@]}"; do
+ # lose the version comparator, if any
+ depname=${dep%%[<>=]*}
+ [[ $depname = $match ]] && echo "$d (depends)"
+ done
+ for dep in "${makedepends[@]}"; do
+ # lose the version comparator, if any
+ depname=${dep%%[<>=]*}
+ [[ $depname = $match ]] && echo "$d (makedepends)"
+ done
+ for dep in "${optdepends[@]/:*}"; do
+ # lose the version comaparator, if any
+ depname=${dep%%[<>=]*}
+ [[ $depname = $match ]] && echo "$d (optdepends)"
+ done
+ fi
+done