summaryrefslogtreecommitdiff
path: root/src/devtools
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-09-11 10:56:46 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-11 15:55:15 -0400
commit6eddc77d5e6abb25f33751308419fa0c62518188 (patch)
tree4f1d004e46d5be3f54efb04d6fd6c5cc6b50c0da /src/devtools
parent2a971c6ad1e55f95f5486b265307160e57b47e5f (diff)
Update to the new version of devtools (huge commit).
User-facing changes: - libremessages: `lock_open_write` became `lock` - libremessages: `lock_open_read` became `slock` - librechroot: learned the `-r` and `-w` flags to do bind mounts. Internal changes: The changes to librechroot were pretty straight-forward; the biggest change is that `archroot` got split into `mkarchroot` and `arch-nspawn`. libremakepkg got a major overhaul Honestly, the changes to libremakepklg probably could have been a lot smaller, but... I wanted to do it right/be clean. makechrootpkg in devtools got cleaned up a lot, actually a lot of the same changes I was making. But, the small differences between the way we did things made it less than simple to adjust. The biggest changes in terms of conflict for me are how devtools now uses bind-mounts to put files in the chroot, and that the /chrootbuild file is more complicated. I handled a lot of the complexity by moving things out of the main program, and adding hooks for non-core functionality, including chcleanup, distcc compatability hacks, and PKGBUILD/pkg checking. Unfortunately, the files containing the hooks are currently hard-coded. Perhaps they will be truly pluggable in the future. That might be neat. Or over-complicated. We'll see where it goes.
Diffstat (limited to 'src/devtools')
-rw-r--r--src/devtools/Makefile9
1 files changed, 0 insertions, 9 deletions
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 6cae230..3fc5d70 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -3,15 +3,6 @@ copy_files = $(addsuffix .in,$(progs))
install_files = $(DESTDIR)$(bindir)/find-libprovides
include ../../common.mk
-# Build ##############################################################
-
-%: %.in Makefile
- @echo "GEN $@"
- @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
- @chmod 755 "$@" || { rm -f -- '$@'; false; }
-
-# Install ############################################################
-
$(DESTDIR)$(bindir)/find-libprovides:
install -d $(@D)
ln -sf find-libdeps $@