summaryrefslogtreecommitdiff
path: root/src/devtools
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-15 17:52:29 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-23 00:06:24 -0600
commit04be9e4ab0bfd1499adda077ecbac21b567e541b (patch)
tree072e64cddfd94e925acaaa22c32da910ca3ccb61 /src/devtools
parentdb321a9205d8902f71be4a6e296ff4b1ae5c6573 (diff)
mv src/devtools/lib/common.sh src/lib/ # and add common-devtools.mk
Diffstat (limited to 'src/devtools')
-rw-r--r--src/devtools/Makefile20
-rw-r--r--src/devtools/lib/common.sh.top13
2 files changed, 1 insertions, 32 deletions
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index ddfdb0f..bca9780 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -1,13 +1,10 @@
topdir = ../..
-include ../../config.mk
+include ../../common-devtools.mk
######################################################################
pkglibexecdir=$(libexecdir)/libretools
-default: all
-all: build
-
######################################################################
copy: \
@@ -16,7 +13,6 @@ copy: \
find-libdeps.in \
finddeps.in \
lddd.in \
- lib/common.sh.in \
lib/makechrootpkg.sh.in
archroot.in: $(devtoolsdir)/mkarchroot.in ; cp $< $@
@@ -24,7 +20,6 @@ checkpkg.in: $(devtoolsdir)/checkpkg.in ; cp $< $@
find-libdeps.in: $(devtoolsdir)/find-libdeps.in ; cp $< $@
finddeps.in: $(devtoolsdir)/finddeps.in ; cp $< $@
lddd.in: $(devtoolsdir)/lddd.in ; cp $< $@
-lib/common.sh.in: $(devtoolsdir)/lib/common.sh ; cp $< $@
lib/makechrootpkg.sh.in: $(devtoolsdir)/makechrootpkg.in ; cp $< $@
######################################################################
@@ -35,11 +30,8 @@ build: \
find-libdeps \
finddeps \
lddd \
- lib/common.sh \
lib/makechrootpkg.sh
-edit = sed -e 's|m4_include(lib/\(.*\))|. $$(librelib \1)|'
-
indent = emacs --batch $1 \
--eval '(setq sh-basic-offset 8)' \
--eval '(indent-region (point-min) (point-max) nil)' \
@@ -50,15 +42,6 @@ indent = emacs --batch $1 \
@$(edit) <"$<" >"$@"
@chmod 755 "$@"
-lib/common.sh: %: %.in %.top Makefile
- @echo "GEN $@"
- @{ \
- cat "$*.top" && \
- echo 'if [[ -z $${_INCLUDE_COMMON_SH:-} ]]; then' && \
- echo '_INCLUDE_COMMON_SH=true' && \
- cat "$*.in" && \
- echo 'fi'; } > "$@"
-
lib/makechrootpkg.sh.ugly: %.ugly: %.in %.patch Makefile
@echo "GEN $@"
@cp $*.in $@
@@ -78,7 +61,6 @@ install: \
$(DESTDIR)$(bindir)/find-libprovides \
$(DESTDIR)$(bindir)/finddeps \
$(DESTDIR)$(bindir)/lddd \
- $(DESTDIR)$(pkglibexecdir)/common.sh \
$(DESTDIR)$(pkglibexecdir)/makechrootpkg.sh
$(DESTDIR)$(sbindir)/%: %
diff --git a/src/devtools/lib/common.sh.top b/src/devtools/lib/common.sh.top
deleted file mode 100644
index d59268d..0000000
--- a/src/devtools/lib/common.sh.top
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/bash -euE
-#!/bin/bash
-# This file is included by libremessages.
-# You should probably use libremessages instead of this.
-
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; version 2 of the License.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.