summaryrefslogtreecommitdiff
path: root/src/diff-unfree
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 00:17:08 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 00:17:08 -0500
commite9bc885c355babf7851de31db8e1920dde752993 (patch)
treefd39b7d6401ead53942f66bfc4219a06f386a23f /src/diff-unfree
parentc74d072dc83c5e3b3d9462678884cd0411a7d1d0 (diff)
organize the files
Diffstat (limited to 'src/diff-unfree')
-rwxr-xr-xsrc/diff-unfree85
1 files changed, 85 insertions, 0 deletions
diff --git a/src/diff-unfree b/src/diff-unfree
new file mode 100755
index 0000000..a0a8d63
--- /dev/null
+++ b/src/diff-unfree
@@ -0,0 +1,85 @@
+#!/bin/bash
+# This script will help you diff a *-libre PKGBUILD against the unfree one
+# to check for updates.
+# Copyright 2010 Nicolás Reynolds
+
+# ---------- GNU General Public License 3 ----------
+
+# This file is part of Parabola.
+
+# Parabola is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# Parabola is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with Parabola. If not, see <http://www.gnu.org/licenses/>.
+
+source /etc/libretools.conf
+custom_config=$XDG_CONFIG_HOME/libretools/libretools.conf
+
+[[ "$1" == "--help" ]] && {
+ msg "Diff-Unfree helps you diff build scripts from ABSLibre against
+ (Unfree) ABS. Package name and repo will we guessed if you don't
+ specify them."
+ msg2 "Usage: $0 [community|packages] [unfree-package] [repo]"
+ exit 0
+}
+
+[[ ! -r PKGBUILD ]] && {
+ error "This is not a build dir."
+ exit 1
+}
+
+package_guess=$(basename $PWD)
+
+repo=${1:-$(basename $(dirname $PWD))}
+package=${2:-${package_guess/-libre}}
+trunk=${3:-trunk}
+
+tmp_dir=$(mktemp -d /tmp/${package}.XXXXXX)
+
+svnrepo="packages"
+case $repo in
+ community*)
+ svnrepo="community"
+ ;;
+ multilib*)
+ svnrepo="community"
+ ;;
+ *)
+ ;;
+esac
+
+unfree_dir="${tmp_dir}/${svnrepo}/${package}/${trunk}"
+
+[[ ! -d "${tmp_dir}" ]] && {
+ error "Can't create temp dir"
+ exit 1
+}
+
+stdnull 'pushd "${tmp_dir}"'
+
+msg "Getting diff from $repo/$package..."
+
+stdnull 'svn checkout --depth=empty svn://svn.archlinux.org/$svnrepo'
+
+cd ${svnrepo}
+svn update ${package}
+
+# Back to start dir
+stdnull popd
+
+msg "Diffing files"
+
+for _file in ${unfree_dir}/*; do
+ msg2 "$(basename "${_file}")"
+ ${DIFFTOOL} "$PWD/$(basename "${_file}")" "${_file}"
+done
+
+exit $?