summaryrefslogtreecommitdiff
path: root/src/fullpkg/fullpkg-find
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-12-09 16:49:34 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-12-09 16:49:34 -0500
commitea6d7a3a6936c86e52889919723caf4549cf13e6 (patch)
treeddfc478f128583c78e8716c59667a1f6ceb972e9 /src/fullpkg/fullpkg-find
parent9728388043af86fefee64336c584f5132273c9bc (diff)
parentd8ebdfe1216c8afbd323218222d43d0f54a0a9fd (diff)
Merge branch 'master' of ssh://parabolagnulinux.org:1863/srv/git/libretools
Diffstat (limited to 'src/fullpkg/fullpkg-find')
-rwxr-xr-xsrc/fullpkg/fullpkg-find3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/fullpkg/fullpkg-find b/src/fullpkg/fullpkg-find
index e188ec8..b09edf9 100755
--- a/src/fullpkg/fullpkg-find
+++ b/src/fullpkg/fullpkg-find
@@ -56,7 +56,6 @@ copy_files() {
# Checks ABSROOT and look for target pkg deps. Adds them if not built or outdated.
find_deps() {
# Check this level
- source /etc/makepkg.conf
source PKGBUILD
local repo="${repo:-$(guess_repo)}"
@@ -131,6 +130,7 @@ find_deps() {
}
source /etc/libretools.conf
+source /etc/makepkg.conf
if [ -e $XDG_CONFIG_HOME/libretools/libretools.conf ]; then
source $XDG_CONFIG_HOME/libretools/libretools.conf
@@ -206,7 +206,6 @@ if [ "$LEVEL" -eq 0 ]; then
msg "Checking dependencies"
fi
-# Find the dependencies on the ABS itself
find_deps
exit 0