summaryrefslogtreecommitdiff
path: root/src/fullpkg/fullpkg
diff options
context:
space:
mode:
authorJoshua I. Haase H. (xihh) <hahj87@gmail.com>2012-12-04 21:19:22 -0600
committerJoshua I. Haase H. (xihh) <hahj87@gmail.com>2012-12-04 21:19:22 -0600
commitacc2c792c423c5aa81aa95f0516de7724dba3ab9 (patch)
tree73cacea8eff5cdfd23f42b740597b5498d152509 /src/fullpkg/fullpkg
parentd11741d73bbf6940c45ee0f2cadea980e9e40785 (diff)
parent098d7430e6447c4658704c3bcf88ea1ed7a5206b (diff)
Merge branch 'master' of gitpar:libretools
Conflicts: librechroot libremakepkg
Diffstat (limited to 'src/fullpkg/fullpkg')
-rwxr-xr-xsrc/fullpkg/fullpkg34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/fullpkg/fullpkg b/src/fullpkg/fullpkg
new file mode 100755
index 0000000..6d6153a
--- /dev/null
+++ b/src/fullpkg/fullpkg
@@ -0,0 +1,34 @@
+#!/bin/bash
+# set -x # uncomment for debug
+# Builds packages from ABS recursively. It tries to find dependencies that
+# aren't built or need update and then makepkg them in order.
+
+usage() {
+
+ echo "cd to a dir containing a PKGBUILD and run:"
+ echo "$0 [build_dir]"
+ echo ""
+ echo "This script will check dependencies, build them if possible "
+ echo "and stage the packages on it's repo."
+ echo ""
+ echo "OPTIONS:"
+ echo " -h : this message."
+ echo ""
+ echo "Wrapper for \`fullpkg-find' and \`fullpkg-build'"
+ echo ""
+ exit 1
+
+}
+
+while getopts 'h' arg; do
+ case "$arg" in
+ h) usage ;;
+ esac
+done
+
+shift $(( OPTIND - 1 ))
+
+build_dir="${1:-$(mktemp -d /tmp/fullpkg.XXXXXX)}"
+fullpkg-find "$build_dir" && fullpkg-build -N "$build_dir"
+
+exit 0