summaryrefslogtreecommitdiff
path: root/src/fullpkg
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-31 18:52:49 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:53:19 -0600
commit1316ba7aa96c69ea541f1b7b3715aad5d1c8eb14 (patch)
treedf265c278a4bcb4823a725b9d78936d6f6fc67ef /src/fullpkg
parent29230b22081f9982f02d1c2fa46834089422d098 (diff)
[all tools]: use conf.sh (and libremessages if necessary)
Diffstat (limited to 'src/fullpkg')
-rwxr-xr-xsrc/fullpkg/fullpkg-build18
-rwxr-xr-xsrc/fullpkg/fullpkg-find9
2 files changed, 10 insertions, 17 deletions
diff --git a/src/fullpkg/fullpkg-build b/src/fullpkg/fullpkg-build
index b497db5..e52bff1 100755
--- a/src/fullpkg/fullpkg-build
+++ b/src/fullpkg/fullpkg-build
@@ -5,13 +5,13 @@
# TODO move __build to chroot
-source /etc/makepkg.conf
-source /etc/libretools.conf
-
-if [ -e $XDG_CONFIG_HOME/libretools/libretools.conf ]; then
- source $XDG_CONFIG_HOME/libretools/libretools.conf
-fi
-
+. libremessages
+. $(librelib conf.sh)
+load_files makepkg
+load_files libretools
+check_vars libretools FULLBUILDCMD || exit 1
+# The following variables are actually optional
+#check_vars libretools HOOKPKGBUILDMOD HOOKLOCALRELEASE || exit 1
## List packages on log that are on status
## usage: list_pkgs <status> <message>
@@ -189,10 +189,6 @@ if "$CHECKNONFREE"; then
check_nonfree
fi
-if [ -z "$FULLBUILDCMD" ]; then
- error "Set your FULLBUILDCMD on libretools.conf"
-fi
-
msg "$MESSAGE"
__build
diff --git a/src/fullpkg/fullpkg-find b/src/fullpkg/fullpkg-find
index b09edf9..dbe65df 100755
--- a/src/fullpkg/fullpkg-find
+++ b/src/fullpkg/fullpkg-find
@@ -129,12 +129,9 @@ find_deps() {
unset next_level dir
}
-source /etc/libretools.conf
-source /etc/makepkg.conf
-
-if [ -e $XDG_CONFIG_HOME/libretools/libretools.conf ]; then
- source $XDG_CONFIG_HOME/libretools/libretools.conf
-fi
+. libremessages
+. $(librelib conf.sh)
+load_files makepkg
LEVEL=0
MAXLEVEL=20