summaryrefslogtreecommitdiff
path: root/src/lib/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-01-05 17:09:11 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-01-05 18:50:09 -0500
commit56384e572d419a48439a90b9481a715a13a109c8 (patch)
treefc132badb5cde0ff2e5713d0cdd2725980306120 /src/lib/Makefile
parentf5663f08d44091ca16c7f53c492c2594202ba7e5 (diff)
src/lib/: set TEXTDOMAIN differently for internal messages
This allows us to fix the long-standing bug that libremessages forces TEXTDOMAIN=libretools
Diffstat (limited to 'src/lib/Makefile')
-rw-r--r--src/lib/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/lib/Makefile b/src/lib/Makefile
index 4f24ad3..4ed5e4f 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -14,7 +14,13 @@ common.sh: %: %.in %.top Makefile
@{ \
cat '$*.top' && \
echo && \
- sed -r -e '/encoding problem/d;/LANG=/d' -e 's/mesg=\$$(.)/mesg="$$(_ "$$\1")"/' '$*.in' && \
+ sed -r \
+ -e '/encoding problem/d;/LANG=/d' \
+ -e 's/mesg=\$$(.)/mesg="$$(_ "$$\1")"/' \
+ -e 's/gettext /_l _ /g' \
+ -e "s/^(\s+)(msg|error) '/\1_l \2 '/" \
+ -e 's|lock\(\)\s*\{|lock()\n{|' \
+ '$*.in' && \
echo && \
cat '$*.bottom' && \
:; } > '$@'