summaryrefslogtreecommitdiff
path: root/src/lib/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-06-27 19:33:06 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-06-27 19:33:06 -0400
commitd7763f0a6cb902e969305d02a18ec13d84227d9d (patch)
treecc343ee3a753bf60aaedc9298c215703c30756e7 /src/lib/Makefile
parentfb94599dcea71cdf2cb448e1545cfbdc526288a1 (diff)
Add librexgettext, to make generating .pot file easy for librelib users.
I don't like how much longer this is than the Makefile, but most of it is option parsing and usage text.
Diffstat (limited to 'src/lib/Makefile')
-rw-r--r--src/lib/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/lib/Makefile b/src/lib/Makefile
index 495abb1..3d2d8f9 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -27,11 +27,12 @@ common.sh: %: %.in %.top Makefile
# Translate ##########################################################
-libreblacklist.pot: libreblacklist
+libreblacklist.pot: libreblacklist librexgettext
{ \
sed -n '/^# Usage:/,/()/{ /^#/ { =; p; } }' $< | \
sed -r -e 's/^# (.*)/msgid "\1"\nmsgstr ""\n/' \
-e 's/^[0-9]*$$/#. embedded usage text\n#: $<:&/'; \
- $(xgettext-sh-prose); \
- $(xgettext-sh-std); \
+ ./librexgettext $<; \
} | $(pofmt) > $@
+
+librexgettext.pot: LIBREXGETTEXT_FLAGS+=--simple=errusage