summaryrefslogtreecommitdiff
path: root/src/lib
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-09-23 20:00:05 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-09-26 16:26:29 -0400
commitd11311f66524dd61b4f186bbbc91d0e47b7e4f4d (patch)
tree71305c620216a15dda02439d64dac7418c1b1baf /src/lib
parent03119e29b4bb744478e6e01922da4d50cf4cbcbc (diff)
Makefile: create a standard 'pot' target
Diffstat (limited to 'src/lib')
-rw-r--r--src/lib/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/lib/Makefile b/src/lib/Makefile
index fd6d31d..4f24ad3 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -3,6 +3,8 @@ libexecs = $(filter-out librelib,$(wildcard libre*))
# include common.sh in libs explicitly, because it might not exist yet
# when the wildcard is performed
libs = $(sort $(wildcard *.sh) common.sh)
+
+pots = $(libs)
include ../../common.mk
# Build ##############################################################
@@ -19,8 +21,6 @@ common.sh: %: %.in %.top Makefile
# Translate ##########################################################
-pot: libreblacklist.pot common.sh.pot librelib.pot
-
libreblacklist.pot: libreblacklist
{ \
sed -n '/^# Usage:/,/()/{ /^#/ { =; p; } }' $< | \