summaryrefslogtreecommitdiff
path: root/src/lib
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-06-20 23:13:30 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-06-20 23:13:30 -0400
commit5c7b1e03c1a9a3405608a78c11823048a3f3ea2f (patch)
tree357ed6eb4d8e78b6abdbcbbaedcc9e77da7344ab /src/lib
parentca2b38d5ef1d6e4756b64d2b5a275c9891802f28 (diff)
fiddle with file locations
I remember now that config.mk's change to ?= was so that xbs Makefiles could override $(binder). That was stupid.
Diffstat (limited to 'src/lib')
-rw-r--r--src/lib/conf.sh8
-rw-r--r--src/lib/conf.sh.3.ronn6
2 files changed, 5 insertions, 9 deletions
diff --git a/src/lib/conf.sh b/src/lib/conf.sh
index 1aa7b56..df189a2 100644
--- a/src/lib/conf.sh
+++ b/src/lib/conf.sh
@@ -51,13 +51,9 @@ list_files() {
echo "$LIBREHOME/.$slug.conf"
fi
;;
- xbs)
- echo /etc/$slug.conf
- echo "$XDG_CONFIG_HOME/$slug.conf"
- ;;
xbs*)
- echo /etc/xbs.d/$slug.conf
- echo "$XDG_CONFIG_HOME/xbs.d/$slug.conf"
+ echo /etc/xbs/$slug.conf
+ echo "$XDG_CONFIG_HOME/xbs/$slug.conf"
;;
libretools)
echo /etc/$slug.conf
diff --git a/src/lib/conf.sh.3.ronn b/src/lib/conf.sh.3.ronn
index 4108f9a..7a4b413 100644
--- a/src/lib/conf.sh.3.ronn
+++ b/src/lib/conf.sh.3.ronn
@@ -1,5 +1,5 @@
conf.sh(3) -- easy loading of configuration files
-==============================================
+=================================================
## SYNOPSIS
@@ -104,8 +104,8 @@ These two routines deal with loading `PKGBUILD`(5) files.
The differences in behavior for anything that takes a slug comes down
to the differences in the output for `list_files` and `list_envvars`.
-The "known" slugs are "abs", "makepkg", and "libretools". If anything
-else is given, then:
+The "known" slugs are "abs", "makepkg", "libretools", and anything
+beginning with "xbs". If anything else is given, then:
* `list_files` will give back "/etc/libretools.d/<SLUG>.conf" and
"$<XDG_CONFIG_HOME>/libretools/<SLUG>.conf"