summaryrefslogtreecommitdiff
path: root/src/librefetch/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 14:46:36 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2017-01-30 18:54:01 -0500
commitdc9339b5699ee3b0d48145a1389f93e9e09d02a6 (patch)
treeed71bd691ea6e0d05d47e2bfd891c333bf5709ab /src/librefetch/Makefile
parent4f9203808ef9607ae27eba3cf77079bbe661fd95 (diff)
Update and tidy the build system for autothing v3.
Diffstat (limited to 'src/librefetch/Makefile')
-rw-r--r--src/librefetch/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/librefetch/Makefile b/src/librefetch/Makefile
index b40c15b..f11f0ed 100644
--- a/src/librefetch/Makefile
+++ b/src/librefetch/Makefile
@@ -1,13 +1,13 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
-libretools-bins = librefetch librefetch-install
-libretools-confs += librefetch-makepkg.conf
-libretools-libexecs += $(filter librefetchdir/%,$(detect-exec))
-libretools-libs += $(filter-out $(libretools-libexecs),$(filter librefetchdir/%,$(detect-all)))
-pots = $(libretools-bins)
+libretools.out.bins = librefetch librefetch-install
+libretools.out.confs = $(libretools.src.conf) librefetch-makepkg.conf
+libretools.out.libexecs = $(filter librefetchdir/%,$(libretools.src.exec))
+libretools.out.libs = $(filter-out $(libretools.out.libexecs),$(filter librefetchdir/%,$(libretools.src.git)))
+libretools.pots = $(libretools.out.bins)
-$(outdir)/librefetch-install: $(var)pkgconfdir
-$(outdir)/librefetch-makepkg.conf: $(var)bindir
+$(outdir)/librefetch-install: $(var.)pkgconfdir
+$(outdir)/librefetch-makepkg.conf: $(var.)bindir
include $(topsrcdir)/build-aux/Makefile.tail.mk