summaryrefslogtreecommitdiff
path: root/src/librefetch/librefetch
diff options
context:
space:
mode:
authorbill-auger <mr.j.spam.me@gmail.com>2020-07-29 20:27:12 -0400
committerbill-auger <mr.j.spam.me@gmail.com>2020-11-20 22:53:31 -0500
commitd86e5248e59c8b90ad102331f8c970e474f92895 (patch)
treefbc4de7ce4de62e8a21a2f5a2f6e03591d556997 /src/librefetch/librefetch
parent48cacf8a34bbc9e7067190f8a250f85c963e52d9 (diff)
update docs
Diffstat (limited to 'src/librefetch/librefetch')
-rwxr-xr-xsrc/librefetch/librefetch20
1 files changed, 9 insertions, 11 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index e91e58a..bc9d57d 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -65,7 +65,7 @@ usage() {
prose "In create mode, it either looks at a build script and uses that
to create the source tarball, or it uses GPG to create a
signature (if OUTPUT_FILE ends with \`.sig\` or \`.sig.part\`).
- If it is using GPG to create a signature, but the file that it is
+ If it is using GPG to create a signature, but the file which it is
trying to sign doesn't exist yet, it recurses on itself to first
create that file. SOURCE_URL is ignored, except that it is used
to set the default value of OUTPUT_FILE, and that it may be used
@@ -80,18 +80,17 @@ usage() {
print "Example usage:"
print ' $ %s https://repo.parabola.nu/other/mypackage/mypackage-1.0.tar.gz' "$cmd"
echo
- print "Options:"
- flag 'Settings:' \
- "-C" "Force create mode (don't download)" \
- "-D" "Force download mode (don't create)" \
+ flag 'Options (behavior):' \
+ "-C" "Force create mode (don't download)" \
+ "-D" "Force download mode (don't create)" \
"-p <$(_ FILE)>" "Use an alternate build script (instead of
'PKGBUILD'). If an SRCBUILD exists in the same
- directory, it is used instead" \
- 'Alternate modes:' \
- "-g, --geninteg" "Generate integrity checks for source files" \
- "-S, --srcbuild" "Print the effective build script (SRCBUILD)" \
+ directory, it is used instead"
+ flag 'Options (reports):' \
+ "-g, --geninteg" "Generate integrity checks for source files" \
+ "-S, --srcbuild" "Print the effective build script (SRCBUILD)" \
"-M, --makepkg" "Generate and print the location of the
- effective makepkg script" \
+ effective makepkg script" \
"-h, --help" "Show this message"
}
@@ -399,7 +398,6 @@ create_signature() {
gpg --detach-sign --use-agent "${SIGNWITHKEY[@]}" --no-armor "$filename" &>/dev/null || ret=$EXIT_FAILURE
-
if (( ! ret )); then
msg2 "Created signature file %s." "$filename.sig"
else