summaryrefslogtreecommitdiff
path: root/src/librefetch
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-07-02 16:39:41 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-07-02 16:39:41 -0400
commit938a711aae6ecf871f37dda71b8e55bebbb6eba8 (patch)
treef5d8c4c5f38295ea948a612c408da2bc06f2af74 /src/librefetch
parent7dd14c9d6869c9d129280358e44edc43eb2ca9bf (diff)
spell-check :/
Diffstat (limited to 'src/librefetch')
-rwxr-xr-xsrc/librefetch/librefetch2
-rw-r--r--src/librefetch/librefetch.8.ronn20
-rw-r--r--src/librefetch/librefetch.conf.5.ronn2
3 files changed, 12 insertions, 12 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 1d8b152..1c793aa 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -67,7 +67,7 @@ usage() {
'PKGBUILD') If an SRCBUILD exists in the same
directory, it is used instead"
print " Alternate modes:"
- flag "-g, --geninteg" "Generage integrity checks for source files"
+ flag "-g, --geninteg" "Generate integrity checks for source files"
flag "-S, --srcbuild" "Print the effective build script (SRCBUILD)"
flag "-M, --makepkg" "Print the effective makepkg script"
flag "-h, --help" "Show this message"
diff --git a/src/librefetch/librefetch.8.ronn b/src/librefetch/librefetch.8.ronn
index 6ee3ce8..3ed462d 100644
--- a/src/librefetch/librefetch.8.ronn
+++ b/src/librefetch/librefetch.8.ronn
@@ -11,7 +11,7 @@ librefetch(8) -- downloads or creates a liberated source tarball
`librefetch` is a program to streamline creation of custom source
tarballs for `PKGBUILD(5)` files.
-If a URL mentioned in the <source> array in a `PKGUILD` is in a
+If a URL mentioned in the <source> array in a `PKGBUILD` is in a
location that Parabola uploads "custom" source tarballs to (or
configured locations), and no file is at that URL, librefetch will
automatically create it for you.
@@ -23,8 +23,8 @@ Because of this, it is almost never necessary to call `librefetch`
manually.
The post-install script also configures `librefetch` as the download
-agent for `libre://` URLs, for compatability with PKGBUILDs that used
-a previous version of librefetch.
+agent for `libre://` URLs, for compatibility with `PKGBUILD` files
+that used a previous version of librefetch.
There are 5 modes:
@@ -51,7 +51,7 @@ fails, it may choose to try `create` mode.
script.
* `-M` | `--makepkg`: Use `makepkg` mode: print the effective makepkg
script.
- * `-h` | `--help`: Use `help` mode: Show useage information.
+ * `-h` | `--help`: Use `help` mode: Show usage information.
Other options, if they are documented in `makepkg -h`, are passed to
the modified copy of makepkg created during `create` mode.
@@ -60,8 +60,8 @@ the modified copy of makepkg created during `create` mode.
If <SOURCE-URL> begins with the string `libre://`, it is replaced with
the first value in <MIRRORS>, as configured in `librefetch.conf(5)`;
-this is for compatability with PKGBUILDs that used a previous version
-of librefetch.
+this is for compatibility with `PKGBUILD` files that used a previous
+version of librefetch.
It uses <DOWNLOADER>, as configured in `librefetch.conf` to attempt to
download the source tarball from that URL. If that fails, and
@@ -126,7 +126,7 @@ this method, the `SRCBUILD` must be deleted (or renamed) for this to
work.
The dynamically created `SRCBUILD` is created by copying `PKGBUILD` to
-a temorary file, then re-setting variables and re-defining functions.
+a temporary file, then re-setting variables and re-defining functions.
Following is a table of the translations.
Variables
@@ -151,19 +151,19 @@ In summary:
* Set <mksource=()> and <mkmd5sums=()> to act as <source=()> and
<md5sums=()>, respectively.
* Declare a `mksource()` function to make modifications to the
- source, if nescessary.
+ source, if necessary.
Other changes:
* <pkgname> is set to <pkgbase>, or the first element of the
- <pkgname> array (the effect is that split packaging is turnes
+ <pkgname> array (the effect is that split packaging is turned
off).
* <options=()> is set have `makepkg` avoid making changes to
<$pkgdir>. The exact change is:
options=(!strip docs libtool staticlibs emptydirs !zipman purge !upx)
- * <PURGE_TARGETS=()> has vcs directories added to it:
+ * <PURGE_TARGETS=()> has VCS directories added to it:
PURGE_TARGETS=(.bzr/ .cvs/ .git/ .hg/ .svn/ .makepkg/)
diff --git a/src/librefetch/librefetch.conf.5.ronn b/src/librefetch/librefetch.conf.5.ronn
index 6158104..29df4d2 100644
--- a/src/librefetch/librefetch.conf.5.ronn
+++ b/src/librefetch/librefetch.conf.5.ronn
@@ -13,7 +13,7 @@ several places it looks for the file are:
* `/etc/libretools.d/librefetch.conf`
* `$XDG_CONFIG_HOME/libretools/librefetch.conf`
-The later files take precidence over earlier files, but earlier files
+The later files take precedence over earlier files, but earlier files
are loaded, so that later files only need to set the values they want
to override.