summaryrefslogtreecommitdiff
path: root/src/librefetch
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-05-31 12:00:47 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-05-31 13:37:23 -0600
commit2a48b40b82770bbc54a79227a52306537bc615d7 (patch)
treecac0163bbc7fe300ffaceca2bd8a3823df3ddb6c /src/librefetch
parent2f0f5979720474ee4e5d7a802cd61c1685be8b38 (diff)
librefetch: Tidy up usage() text.
Diffstat (limited to 'src/librefetch')
-rwxr-xr-xsrc/librefetch/librefetch22
1 files changed, 11 insertions, 11 deletions
diff --git a/src/librefetch/librefetch b/src/librefetch/librefetch
index 45df21b..49a8565 100755
--- a/src/librefetch/librefetch
+++ b/src/librefetch/librefetch
@@ -60,17 +60,17 @@ usage() {
print ' $ %s https://repo.parabola.nu/other/mypackage/mypackage-1.0.tar.gz' "$cmd"
echo
print "Options:"
- print " Settings:"
- flag "-C" "Force create mode (don't download)"
- flag "-D" "Force download mode (don't create)"
- flag "-p <$(_ FILE)>" "Use an alternate build script (instead of
- 'PKGBUILD') If an SRCBUILD exists in the same
- directory, it is used instead"
- print " Alternate modes:"
- flag "-g, --geninteg" "Generate integrity checks for source files"
- flag "-S, --srcbuild" "Print the effective build script (SRCBUILD)"
- flag "-M, --makepkg" "Print the effective makepkg script"
- flag "-h, --help" "Show this message"
+ flag 'Settings:' \
+ "-C" "Force create mode (don't download)" \
+ "-D" "Force download mode (don't create)" \
+ "-p <$(_ FILE)>" "Use an alternate build script (instead of
+ 'PKGBUILD'). If an SRCBUILD exists in the same
+ directory, it is used instead" \
+ 'Alternate modes:' \
+ "-g, --geninteg" "Generate integrity checks for source files" \
+ "-S, --srcbuild" "Print the effective build script (SRCBUILD)" \
+ "-M, --makepkg" "Print the effective makepkg script" \
+ "-h, --help" "Show this message"
}
main() {