summaryrefslogtreecommitdiff
path: root/src/libretools.conf
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 11:10:11 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-11-07 11:10:11 -0500
commit84442a551d28dc504b3b38e1dcfc99dd56c52dea (patch)
tree7d47b10350f359b4233db98e4eeac799e4c0d67c /src/libretools.conf
parentfa8e8a2a9770391530134272bd4da3ec0ecb6b9e (diff)
mv libretools.conf src/
Diffstat (limited to 'src/libretools.conf')
-rw-r--r--src/libretools.conf122
1 files changed, 122 insertions, 0 deletions
diff --git a/src/libretools.conf b/src/libretools.conf
new file mode 100644
index 0000000..8032397
--- /dev/null
+++ b/src/libretools.conf
@@ -0,0 +1,122 @@
+## Blacklist URL
+BLACKLIST=http://repo.parabolagnulinux.org/docs/blacklist.txt
+
+# Diff tool (vimdiff, gvimdiff, meld, etc)
+DIFFTOOL=vimdiff
+
+# The dir where you work on
+WORKDIR=/home/$USER/packages
+# The repos you'll be packaging for
+#
+# Tip: As early repos take precedence on $REPOS loops, you can use this as
+# inverted order of precedence. Put testing repos first so fullpkg find new
+# PKGBUILDs first, for instance. Toru-path uses reverse order to enforce repo
+# precedence on the path cache (the last path added replaces the rest)
+REPOS=('core' 'libre' 'extra' 'community' 'libre-testing' 'social' 'sugar')
+
+# The architectures
+ARCHES=('i686' 'x86_64' 'mips64el' 'any')
+
+## The directory where the chroots are stored
+CHROOTDIR=/home/chroot
+# Extra packages to have installed on the chroot (besides base base-devel and sudo)
+CHROOTEXTRAPKG=(distcc ccache tsocks tokyocabinet)
+
+## The working chroot
+## A chroot is useful to build packages isolated from the current system and avoid
+## unwanted (as in not in dependencies) automatic library linking
+# CHROOT=$SUDO_USER
+# CHROOT=root
+
+## Obtains CacheDir from pacman.conf
+CACHEDIR=`grep "^#\?CacheDir" /etc/pacman.conf | cut -d'=' -f2`
+
+## Parabola hostname (should be the same used on ssh_config
+PARABOLAHOST=parabola
+
+## Server destination of libre packages
+# Don't change unless you know what you're doing and you won't screw
+# anything ;)
+LIBREDESTDIR=/srv/http/repo/public
+
+## ABSLibre
+ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git
+
+## Commit Command
+## Should be git or hg
+## Uncomment only one of those
+#COMMITCMD=git
+#COMMITCMD=hg
+
+## Uncomment one of those or make one of your choice
+# Normal fullpkg
+FULLBUILDCMD="sudo libremakepkg -cuN"
+# Cross compiling fullkpg
+# FULLBUILDCMD="sudo libremakepkg -cuN -d '/path/to/cross-compiling/chroot'"
+# Build from within the chroot (or host system)
+# FULLBUILDCMD="makepkg -sL --noconfirm"
+
+# Run a command before releasing a package (ie. SSH connection, SSH tunnel, etc.)
+HOOKPRERELEASE="ssh -fN parabola"
+
+# Run a command before running FULLBUILDCMD, usually to cleanup uneeded packages
+# Note! chcleanup *is not* chroot aware, if you run it as it is it will cleanup
+# your system
+# HOOKPREBUILD="chcleanup"
+
+# Locally release the package or any other action after running FULLBUILDCMD
+# succesfully
+# HOOKLOCALRELEASE=""
+
+## Toru
+# Section for toru's vars
+TORUPATH=/var/lib/libretools/toru
+
+## Package signing
+# Leave commented to disable signing
+#SIGEXT=".sig"
+#SIGID="0xYOURID"
+
+# Checks if vars aren't empty
+
+for VAR in CHROOTDIR CHROOT CACHEDIR PARABOLAHOST LIBREDESTDIR \
+ BLACKLIST WORKDIR REPOS ARCHES ABSLIBREGIT \
+ COMMITCMD DIFFTOOL FULLBUILDCMD; do
+
+ ret=0
+ [[ -z ${!VAR} ]] && {
+ echo "Configure $VAR var in /etc/libretools.conf"
+ ret=1
+ }
+ [ $ret -ne 0 ] && exit 1
+done
+
+source /usr/bin/libremessages
+
+## These are architecture specific files.
+## Uncomment them if you installed libretools-mips64el
+# source /etc/libretools.d/mips64el.conf
+
+## Recommended SSH Config follows
+# SSH host, it's better if you have it configured on ~/.ssh/config
+# with ControlMaster auto (and a shell opened somewhere else)
+#
+# Example:
+# Host *
+# Protocol 2
+# ControlMaster auto
+# ControlPath /tmp/ssh-%r@%h:%p
+#
+## Repo server
+# Host parabola
+# Port 22
+# HostName repo.parabolagnulinux.org
+# User parabolavnx
+# IdentityFile ~/.ssh/id_rsa
+#
+## Git server
+# Host vparabola
+# Port 1863
+# HostName parabolagnulinux.org
+# User parabola
+# IdentityFile ~/.ssh/id_rsa