summaryrefslogtreecommitdiff
path: root/src/libretools.conf
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-31 22:58:20 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:53:19 -0600
commitd0665ee79d9e7dad960cfd7166987905d191bf80 (patch)
tree1b421220767b4a980f84ab90f4e085a8dd6b4bfd /src/libretools.conf
parent1316ba7aa96c69ea541f1b7b3715aad5d1c8eb14 (diff)
clean up configuration files
Diffstat (limited to 'src/libretools.conf')
-rw-r--r--src/libretools.conf60
1 files changed, 27 insertions, 33 deletions
diff --git a/src/libretools.conf b/src/libretools.conf
index df0471e..3ca1fda 100644
--- a/src/libretools.conf
+++ b/src/libretools.conf
@@ -5,15 +5,18 @@
################################################################################
## Blacklist URL
-## Used by `pkgbuild-check-nonfree`
BLACKLIST=https://repo.parabolagnulinux.org/docs/blacklist.txt
## Diff tool (vimdiff, gvimdiff, meld, etc)
## Used by `aur`, `diff-unfree`
DIFFTOOL=`which vimdiff gvimdiff meld colordiff diff 2>/dev/null|sed 's/\s.*//;1q'`
+## Where to put generated patches
+## Used by `librediff`
+PATCHDIR=/home/$LIBREUSER/packages/patches
+
## The repos you'll be packaging for
-## Used by `toru`, `createworkdir`, `prfullpkg`
+## Used by `toru`, `createworkdir`
# Tip: As early repos take precedence on $REPOS loops, you can use this as
# inverted order of precedence. Put testing repos first so fullpkg find new
# PKGBUILDs first, for instance. Toru-path uses reverse order to enforce repo
@@ -29,7 +32,7 @@ ARCHES=('i686' 'x86_64' 'mips64el' 'any')
################################################################################
# The dir where you work on
-WORKDIR=/home/$USER/packages
+WORKDIR=/home/$LIBREUSER/packages
## Package signing
SIGEXT=".sig"
@@ -53,46 +56,37 @@ LIBREDESTDIR=/srv/http/repo/public
## ABSLibre
ABSLIBREGIT=http://projects.parabolagnulinux.org/abslibre.git
+# Run a command before releasing a package (ie. SSH connection, SSH tunnel, etc.)
+# This is called by librerelease.
+HOOKPRERELEASE="ssh -fN parabola"
+
################################################################################
-# fullpkg #
+# fullpkg/treepkg #
################################################################################
+# NOTE: fullpkg ONLY
+#HOOKPKGBUILDMOD="mips-add"
+
+# Run a command before running FULLBUILDCMD, usually to cleanup uneeded packages
+# Note: Recent versions of libremakepkg run chcleanup for you.
+# NOTE: treepkg ONLY
+#HOOKPREBUILD="chcleanup"
+
## Uncomment one of those or make one of your choice
-# Normal fullpkg
+# Normal
FULLBUILDCMD="sudo libremakepkg"
-# Cross compiling fullkpg
-# FULLBUILDCMD="sudo libremakepkg -n cross-compile-chroot"
-# Build from within the chroot (or host system)
-# FULLBUILDCMD="makepkg -sL --noconfirm"
-
-# Run a command before releasing a package (ie. SSH connection, SSH tunnel, etc.)
-HOOKPRERELEASE="ssh -fN parabola"
+# Cross compiling
+#FULLBUILDCMD="sudo libremakepkg -n cross-compile-chroot"
+# Don't use a chroot
+#FULLBUILDCMD="makepkg -sL --noconfirm"
-# Run a command before running FULLBUILDCMD, usually to cleanup uneeded packages
-# Note! chcleanup *is not* chroot aware, if you run it as it is it will cleanup
-# your system
-# HOOKPREBUILD="chcleanup"
-
# Locally release the package or any other action after running FULLBUILDCMD
-# succesfully
-# HOOKLOCALRELEASE=""
+# succesfully.
+HOOKLOCALRELEASE=":"
+#HOOKLOCALRELEASE="mipsrelease"
################################################################################
# toru #
################################################################################
TORUPATH=/var/lib/libretools/toru
-
-################################################################################
-# Stub for old programs; wouldn't normally be in a .conf file #
-################################################################################
-
-if [[ -z ${INCLUDE_CONF_SH:-} ]]; then
- . $(librelib conf.sh)
- if [[ -e "$XDG_CONFIG_HOME/libretools/libretools.conf" ]]; then
- . "$XDG_CONFIG_HOME/libretools/libretools.conf"
- fi
- check_conf_libretools || exit $?
-
- . libremessages
-fi