summaryrefslogtreecommitdiff
path: root/src/mips64el-tools
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-27 21:15:00 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-27 21:15:00 -0600
commitb369d323c9859290e2f29c6d07e7f0394ed88cd9 (patch)
treeb0454d30775d3ab662b9c4c9e4bd24094c98ce19 /src/mips64el-tools
parent81c44824f174eda5f57c396cc7d91e2c97490d93 (diff)
add {load,unset}_PKGBUILD to conf.sh, use it.
There are a bunch of caveats to loading a PKGBUILD file. This way it is all done correctly in one place. unset_PKGBUILD unsets any functions and variables that are normally set in a PKGBUILD. The list is far more complete than any existing implementation. load_PKGBUILD loads the file given, or "./PKGBUILD" if none is given. But first it calls unset_PKGBUILD and then sets CARCH.
Diffstat (limited to 'src/mips64el-tools')
-rwxr-xr-xsrc/mips64el-tools/mipsrelease2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/mips64el-tools/mipsrelease b/src/mips64el-tools/mipsrelease
index bd7e217..fc0d904 100755
--- a/src/mips64el-tools/mipsrelease
+++ b/src/mips64el-tools/mipsrelease
@@ -35,7 +35,7 @@ main() {
fi
# Get all needed sources
- source PKGBUILD
+ load_PKGBUILD
pkgs=()
makepkg --source -f --skippgpcheck