summaryrefslogtreecommitdiff
path: root/src/mips64el-tools
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-03-23 18:09:13 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-03-23 18:09:13 -0400
commit222856031fbbf314e8e47db414225756a9c6fba2 (patch)
treebb79c3265c674380ff1066dfd71658c89b88ee75 /src/mips64el-tools
parentff15727c30e5b9af5225869e38cbcfa2b08da6c2 (diff)
Most of my desired re-licensings were authorized on the dev list
Diffstat (limited to 'src/mips64el-tools')
-rwxr-xr-xsrc/mips64el-tools/add-mips64el15
-rwxr-xr-xsrc/mips64el-tools/mips-add15
2 files changed, 28 insertions, 2 deletions
diff --git a/src/mips64el-tools/add-mips64el b/src/mips64el-tools/add-mips64el
index bf04663..bb1bb69 100755
--- a/src/mips64el-tools/add-mips64el
+++ b/src/mips64el-tools/add-mips64el
@@ -3,7 +3,20 @@
# Copyright (C) 2011 Nicolás Reynolds <fauno@parabola.nu>
#
-# License: Unspecified
+# License: GNU GPLv3+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
find -name 'PKGBUILD' -exec sed -i "s/^\(arch=([^)anym]\+\))/\1 'mips64el')/" '{}' \;
diff --git a/src/mips64el-tools/mips-add b/src/mips64el-tools/mips-add
index 11f6a74..ef708ec 100755
--- a/src/mips64el-tools/mips-add
+++ b/src/mips64el-tools/mips-add
@@ -1,7 +1,20 @@
#!/usr/bin/env bash
# Copyright (C) 2011 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
#
-# License: Unspecified
+# License: GNU GPLv3+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
. libremessages
if ! grep mips64el PKGBUILD >/dev/null; then # Add mips64el in ${arch} array if it isn't 'any'