summaryrefslogtreecommitdiff
path: root/src/pkgbuild-check-nonfree
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2017-04-20 23:05:01 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2017-04-20 23:19:37 -0400
commitcdc456c8b7c6e3eb4b11d668fb9c6e9bdec7230e (patch)
treed54d0c816a146023fbc7a54c0d5f71ecd0e69937 /src/pkgbuild-check-nonfree
parent23213bda24af601acbbea5731246a055680b48d0 (diff)
Don't use subshells in local/export/declare commands.
Only make this change in places where it shouldn't make a difference, and something weird has to be going on for the subshell to fail. This is on par with checking the return value of malloc. We don't need tests for each of these failure cases.
Diffstat (limited to 'src/pkgbuild-check-nonfree')
-rwxr-xr-xsrc/pkgbuild-check-nonfree7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/pkgbuild-check-nonfree b/src/pkgbuild-check-nonfree
index e291dbe..59ec7c9 100755
--- a/src/pkgbuild-check-nonfree
+++ b/src/pkgbuild-check-nonfree
@@ -83,7 +83,7 @@ main() {
done
shift $((OPTIND - 1))
if [[ $# -lt 1 ]]; then
- pkgbuilds=("`pwd`/PKGBUILD")
+ pkgbuilds=("$PWD/PKGBUILD")
else
pkgbuilds=("$@")
fi
@@ -190,8 +190,9 @@ check_dep() {
[[ $# == 1 ]] || panic 'malformed call to check_dep'
local pkg=$1
- local line="$(blacklist-cat|blacklist-lookup "$pkg")"
- local rep="$(blacklist-get-rep <<<"$line")"
+ local line rep
+ line="$(blacklist-cat|blacklist-lookup "$pkg")"
+ rep="$(blacklist-get-rep <<<"$line")"
if [[ -z $line ]]; then
# not mentioned in blacklist; free
info '%s: not blacklisted' "$pkg"