summaryrefslogtreecommitdiff
path: root/src/pkgbuild-check-nonfree
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:36:55 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 20:01:07 -0600
commitbeae9b3e2822021fea741fc98282cf9e0fc1d024 (patch)
treeab2c55df74fb068050be1f293b9a9df24721f24f /src/pkgbuild-check-nonfree
parent1d6066b37e0fd4e7118a3d366d1b6a2168a70286 (diff)
Double bracket ==/</> compare lexicographically, not numerically.
Unfortunately for me, that means that it works correctly *most* of the time. But, for example, [[ 10 < 2 ]], and negatives don't work.
Diffstat (limited to 'src/pkgbuild-check-nonfree')
-rwxr-xr-xsrc/pkgbuild-check-nonfree2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/pkgbuild-check-nonfree b/src/pkgbuild-check-nonfree
index 9a5e440..92496be 100755
--- a/src/pkgbuild-check-nonfree
+++ b/src/pkgbuild-check-nonfree
@@ -101,7 +101,7 @@ main() {
esac
done
shift $(($OPTIND - 1))
- if [[ $# < 1 ]]; then
+ if [[ $# -lt 1 ]]; then
pkgbuilds=("`pwd`/PKGBUILD")
else
pkgbuilds=("$@")