summaryrefslogtreecommitdiff
path: root/src/toru/toru-path
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-06-06 16:17:39 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-06-06 16:17:39 -0600
commit2816cab18aae8bc8c7fc796cdfa938c8f15cd0c8 (patch)
treee98cb58a743d5bab0ea0052c6033b59e0bea3b6f /src/toru/toru-path
parentdebfee16574015051424a3785715ebb92012ffbd (diff)
toru-utils: tidy up
- use libremessages:setup_traps instead of the copy/pasted solution - get_pkgbuilds: don't leak the "extra" variable - fix up quoting - get_pkgbuilds: don't use the global LASTSYNCFILE, get it as an argument * toru-path: adjust for this
Diffstat (limited to 'src/toru/toru-path')
-rwxr-xr-xsrc/toru/toru-path2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/toru/toru-path b/src/toru/toru-path
index 6d9ae8e..a81ee53 100755
--- a/src/toru/toru-path
+++ b/src/toru/toru-path
@@ -44,7 +44,7 @@ for (( i = ${#REPOS[@]}-1 ; i >= 0 ; i-- )); do
[ -d "${ABSROOT}${REPOS[$i]}" ] && \
fullrepos+=("${ABSROOT}${REPOS[$i]}")
done
-pkgbuilds=($(get_pkgbuilds ${fullrepos[@]}))
+pkgbuilds=($(get_pkgbuilds "${LASTSYNCFILE}" "${fullrepos[@]}"))
msg "Updating path cache"
msg2 "${#pkgbuilds[@]} PKGBUILDs to update"