summaryrefslogtreecommitdiff
path: root/src/toru/toru-path
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-06-06 17:14:20 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-06-06 17:14:20 -0600
commit862b7754b83b40c79f805146170c23afcd3af00c (patch)
treee7ac1a28378b6afe26a583e51ec993a600e79bd4 /src/toru/toru-path
parent508e7c547dacb8b930885fd61057cb8d2868aaf8 (diff)
meld toru-utils into toru-path, since it is the only thing using it
Diffstat (limited to 'src/toru/toru-path')
-rwxr-xr-xsrc/toru/toru-path42
1 files changed, 41 insertions, 1 deletions
diff --git a/src/toru/toru-path b/src/toru/toru-path
index 7fc6dfe..888a5e4 100755
--- a/src/toru/toru-path
+++ b/src/toru/toru-path
@@ -2,6 +2,7 @@
# Copyright (C) 2011-2012 Nicolás Reynolds <fauno@parabola.nu>
# Copyright (C) 2012 Michał Masłowski <mtjm@mtjm.eu>
+# Copyright (C) 2012 Joshua Ismael Haase Hernández (xihh) <hahj87@gmail.com>
#
# License: GNU GPLv3+
#
@@ -18,10 +19,49 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-source toru-utils
+. libremessages
+. "$(librelib conf.sh)"
+load_files libretools
+check_vars libretools TORUPATH REPOS || exit 1
+load_files abs
+check_vars abs ABSROOT || exit 1
+
+setup_traps
TORUPATH=${T:-${TORUPATH}}
VERBOSE=${V:-false}
+FORCE=false
+
+# Stores the lastsync date
+lastsync() {
+ local lastsyncfile="$1"
+
+ if [[ -e "${lastsyncfile}" -a ! -w "${lastsyncfile}" ]]; then
+ error "The sync date can't be saved: file not writable: %q" "${lastsyncfile}"
+ return 1
+ fi
+
+ date +%s > "${lastsyncfile}"
+ touch "${lastsyncfile}"
+}
+
+# repo paths
+get_pkgbuilds() {
+ local lastsyncfile="$1"; shift
+ # Only find newer than lastsyncfile and read
+ # everything else from cache
+ local extra=(-newer "${lastsyncfile}")
+
+ if [[ $FORCE = true || ! -e ${lastsyncfile} ]]; then
+
+ ${VERBOSE} && warning "Forcing upgrade"
+ # Get all PKGBUILDs
+ extra=()
+ fi
+
+ # Return all PKGBUILDs found
+ find "$@" -mindepth 2 -maxdepth 3 -type f -name 'PKGBUILD' "${extra[@]}"
+}
if [ ! -w "$TORUPATH" ]; then
error "Toru's path isn't writable. Please check $TORUPATH"