summaryrefslogtreecommitdiff
path: root/src/toru
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-05-31 18:52:49 -0600
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-06-05 19:53:19 -0600
commit1316ba7aa96c69ea541f1b7b3715aad5d1c8eb14 (patch)
treedf265c278a4bcb4823a725b9d78936d6f6fc67ef /src/toru
parent29230b22081f9982f02d1c2fa46834089422d098 (diff)
[all tools]: use conf.sh (and libremessages if necessary)
Diffstat (limited to 'src/toru')
-rwxr-xr-xsrc/toru/toru-info2
-rwxr-xr-xsrc/toru/toru-utils20
-rwxr-xr-xsrc/toru/toru-where4
3 files changed, 8 insertions, 18 deletions
diff --git a/src/toru/toru-info b/src/toru/toru-info
index 523f682..5b6fd01 100755
--- a/src/toru/toru-info
+++ b/src/toru/toru-info
@@ -1,6 +1,6 @@
#!/bin/bash
# Prints info about a given pkgname
-source /etc/libretools.conf
+. libremessages
for _pkg in $@; do
_pkgbuild="$(toru-where $_pkg)"
diff --git a/src/toru/toru-utils b/src/toru/toru-utils
index 316e6b8..acf3776 100755
--- a/src/toru/toru-utils
+++ b/src/toru/toru-utils
@@ -1,27 +1,15 @@
#!/bin/bash
-source /etc/abs.conf
-source /etc/libretools.conf
+. libremessages
+. $(librelib conf.sh)
+load_files libretools
+check_vars libretools TORUPATH || exit 1
LASTSYNCFILE=${TORUPATH}/lastsync
FORCE=false
QUIET=false
DEBUG=false
-# usage : in_array( $needle, $haystack )
-function in_array {
- [[ $2 ]] || return 1 # Not found
-
- local needle=$1; shift
- local item
-
- for item in "$@"; do
- [[ ${item#@} = $needle ]] && return 0 # Found
- done
-
- return 1 # Not Found
-}
-
# Stores the lastsync date
lastsync() {
local lastsyncfile
diff --git a/src/toru/toru-where b/src/toru/toru-where
index e9ab29d..8af3fb2 100755
--- a/src/toru/toru-where
+++ b/src/toru/toru-where
@@ -1,6 +1,8 @@
#!/bin/bash
# Locates a PKGBUILD dir on toru's path cache
-source /etc/libretools.conf
+. $(librelib conf.sh)
+load_files libretools
+check_vars libretools TORUPATH || exit 1
PATHFILE=${TORUPATH}/paths.tch