summaryrefslogtreecommitdiff
path: root/src/xbs-abs/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2014-07-05 02:10:21 -0400
committerLuke Shumaker <lukeshu@sbcglobal.net>2014-07-05 18:08:41 -0400
commitac6c975cde77b1fa8f3a8df2f9c966b3dc5fc90c (patch)
tree56f8a52bd5ac62f2240c46305f8baa425db30073 /src/xbs-abs/Makefile
parent8435815a7690830dece329ac9a71b1da04f4ba38 (diff)
xbs: create separate release-client and release-server sub-commands
Diffstat (limited to 'src/xbs-abs/Makefile')
-rw-r--r--src/xbs-abs/Makefile21
1 files changed, 17 insertions, 4 deletions
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
index cac9aea..8688ed7 100644
--- a/src/xbs-abs/Makefile
+++ b/src/xbs-abs/Makefile
@@ -1,10 +1,23 @@
pkgconfdir = $(sysconfdir)/xbs
pkglibexecdir = $(libexecdir)/xbs
libexecs = helper-abs
-no-progs = $(libexecs) archrelease
-copy_files = archrelease.in
-install_files = $(DESTDIR)$(pkglibexecdir)/helper-abs.d/archrelease
+
+_helpers = archrelease commitpkg
+no-progs = $(libexecs) $(_helpers)
+copy_files = $(addsuffix .in,$(_helpers))
+install_files = $(addprefix $(DESTDIR)$(pkglibexecdir)/helper-abs.d/,$(_helpers))
+pots = $(_helpers)
+
include ../../common.mk
-$(DESTDIR)$(pkglibexecdir)/helper-abs.d/archrelease: archrelease
+commitpkg: commitpkg.in
+ { \
+ echo '#!/usr/bin/env bash'; \
+ echo '. "$$(librelib common)"'; \
+ echo '. ./PKGBUILD'; \
+ echo 'repo=$$1; arch=$$2;'; \
+ sed -n "/== 'any'/,\$$p" $<; \
+ } > $@
+
+$(DESTDIR)$(pkglibexecdir)/helper-abs.d/%: %
install -Dm755 '$<' '$@'