summaryrefslogtreecommitdiff
path: root/src/xbs-abs/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2013-11-29 17:57:39 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2013-11-29 18:15:37 -0500
commit8f67551473004a9487fa47cf7f9e953c4c46cd7f (patch)
tree146cbeaf175d126c812447d46677717ef12993ef /src/xbs-abs/Makefile
parent4408cd8cf638c786338ed1123f93fc1e4dc67279 (diff)
initial implementation of xbs-abs
Diffstat (limited to 'src/xbs-abs/Makefile')
-rw-r--r--src/xbs-abs/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
new file mode 100644
index 0000000..7582592
--- /dev/null
+++ b/src/xbs-abs/Makefile
@@ -0,0 +1,12 @@
+pkgconfdir = $(sysconfdir)/xbs
+bindir = $(libexecdir)/xbs
+pkglibexecdir = $(libexecdir)/xbs/helper-abs.d
+copy_files = archrelease.in
+libs = archrelease
+include ../../common.mk
+
+archrelease: %: %.in
+ @echo "GEN $@"
+ @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
+ @sed -i '/valid-tags\.sh/d' '$@' || { rm -f -- '$@'; false; }
+ @chmod 755 "$@" || { rm -f -- '$@'; false; }