summaryrefslogtreecommitdiff
path: root/src/xbs-abs
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-06-20 23:13:30 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-06-20 23:13:30 -0400
commit5c7b1e03c1a9a3405608a78c11823048a3f3ea2f (patch)
tree357ed6eb4d8e78b6abdbcbbaedcc9e77da7344ab /src/xbs-abs
parentca2b38d5ef1d6e4756b64d2b5a275c9891802f28 (diff)
fiddle with file locations
I remember now that config.mk's change to ?= was so that xbs Makefiles could override $(binder). That was stupid.
Diffstat (limited to 'src/xbs-abs')
-rw-r--r--src/xbs-abs/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
index ed969eb..c882807 100644
--- a/src/xbs-abs/Makefile
+++ b/src/xbs-abs/Makefile
@@ -1,6 +1,9 @@
pkgconfdir = $(sysconfdir)/xbs
-bindir = $(libexecdir)/xbs
-pkglibexecdir = $(libexecdir)/xbs/helper-abs.d
+pkglibexecdir = $(libexecdir)/xbs
+libexecs = helper-abs
copy_files = archrelease.in
-libs = archrelease
+install_files = $(DESTDIR)$(pkglibexecdir)/helper-abs.d/archrelease
include ../../common.mk
+
+$(DESTDIR)$(pkglibexecdir)/helper-abs.d/archrelease: archrelease
+ install -Dm755 '$<' '$@'