summaryrefslogtreecommitdiff
path: root/src/xbs-abs
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-06-20 22:00:01 -0400
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-06-20 22:00:01 -0400
commitbec95eeaee02dffb0f1750b9ca2641378bbe9df9 (patch)
tree394fe1663327f85451bfbd290df844717de5db7c /src/xbs-abs
parent58247a8f992a7c5957292d95fe6919b3fcacbf87 (diff)
I think xbs is in a workable stage.
Diffstat (limited to 'src/xbs-abs')
-rw-r--r--src/xbs-abs/Makefile6
-rwxr-xr-xsrc/xbs-abs/helper-abs14
-rw-r--r--src/xbs-abs/xbs-abs.conf4
3 files changed, 12 insertions, 12 deletions
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
index 7582592..ed969eb 100644
--- a/src/xbs-abs/Makefile
+++ b/src/xbs-abs/Makefile
@@ -4,9 +4,3 @@ pkglibexecdir = $(libexecdir)/xbs/helper-abs.d
copy_files = archrelease.in
libs = archrelease
include ../../common.mk
-
-archrelease: %: %.in
- @echo "GEN $@"
- @$(edit) <"$<" >"$@" || { rm -f -- '$@'; false; }
- @sed -i '/valid-tags\.sh/d' '$@' || { rm -f -- '$@'; false; }
- @chmod 755 "$@" || { rm -f -- '$@'; false; }
diff --git a/src/xbs-abs/helper-abs b/src/xbs-abs/helper-abs
index d2baf42..387c1a6 100755
--- a/src/xbs-abs/helper-abs
+++ b/src/xbs-abs/helper-abs
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
# Copyright (C) 2013 Luke Shumaker <lukeshu@sbcglobal.net>
#
@@ -140,8 +140,8 @@ move() {
local arches=()
# this is based off code from dbscripts:db-move
for pkgarch in "${ARCHES[@]}" 'any'; do
- dir_from="${svndir}/repos/${repo_from}-${pkgarch}"
- dir_to="${svndir}/repos/${repo_to}-${pkgarch}"
+ local dir_from="${svndir}/repos/${repo_from}-${pkgarch}"
+ local dir_to="${svndir}/repos/${repo_to}-${pkgarch}"
if [ -f "${dir_from}/PKGBUILD" ]; then
if [ -d "${dir_to}" ]; then
@@ -153,6 +153,7 @@ move() {
arch_svn add -q "${dir_to}"
fi
+ local file
for file in $(arch_svn ls "${dir_from}"); do
arch_svn mv -q -r HEAD "${dir_from}/$file@" "${dir_to}/"
done
@@ -174,7 +175,12 @@ releasepath() {
load_config
local svndir="${SVNDIR}/$(pac2svn "$repo")/${pkgbase}"
arch_svn up -q "${svndir}"
- echo "${svndir}/repos/${repo}-${arch}"
+ local releasepath="${svndir}/repos/${repo}-${arch}"
+ if [[ -f "${releasepath}/PKGBUILD" ]]; then
+ printf '%s\n' "$releasepath"
+ return 0
+ fi
+ return 1
}
case "$1" in
diff --git a/src/xbs-abs/xbs-abs.conf b/src/xbs-abs/xbs-abs.conf
index 3ceba6a..b542707 100644
--- a/src/xbs-abs/xbs-abs.conf
+++ b/src/xbs-abs/xbs-abs.conf
@@ -3,8 +3,8 @@ SVNDIR=/var/lib/xbs-abs
# name url repos...
SVNREPOS=(
- 'packages svn://svn.archlinux.org/packages core extra testing'
- 'commuity svn://svn.archlinux.org/community community community-testing multilib multilib-testing'
+ 'packages svn://svn.archlinux.org/packages core extra testing staging kde-unstable gnome-unstable'
+ "commuity svn://svn.archlinux.org/community $(echo {community,multilib}{,-testing,-staging})"
)
ARCHES=(i686 x86_64)