summaryrefslogtreecommitdiff
path: root/src/xbs-abslibre/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
commit7e704d7ac997387341e920e1757c24cac0efe5e9 (patch)
treea9f30eabaaad5496397a91053d3e03bab1ea57e4 /src/xbs-abslibre/Makefile
parent7785a72495e3eb0ea826b41720c241f58a15b601 (diff)
Refactor the build system. Avoid recursive make.
This looks like a lot, but more things should "just work". We have `make dist` now!
Diffstat (limited to 'src/xbs-abslibre/Makefile')
-rw-r--r--src/xbs-abslibre/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/xbs-abslibre/Makefile b/src/xbs-abslibre/Makefile
index 420ae52..6c61803 100644
--- a/src/xbs-abslibre/Makefile
+++ b/src/xbs-abslibre/Makefile
@@ -1,4 +1,8 @@
+include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
+include $(topsrcdir)/automake.head.mk
pkglibexecdir = $(libexecdir)/xbs
-libexecs = helper-abslibre
-no-progs = $(libexecs)
-include ../../common.mk
+
+install-bins =
+install-libexecs = helper-abslibre
+
+include $(topsrcdir)/automake.tail.mk