summaryrefslogtreecommitdiff
path: root/src/xbs/Makefile
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
committerLuke Shumaker <lukeshu@sbcglobal.net>2016-02-08 16:36:45 -0500
commit7e704d7ac997387341e920e1757c24cac0efe5e9 (patch)
treea9f30eabaaad5496397a91053d3e03bab1ea57e4 /src/xbs/Makefile
parent7785a72495e3eb0ea826b41720c241f58a15b601 (diff)
Refactor the build system. Avoid recursive make.
This looks like a lot, but more things should "just work". We have `make dist` now!
Diffstat (limited to 'src/xbs/Makefile')
-rw-r--r--src/xbs/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/xbs/Makefile b/src/xbs/Makefile
index ea5e924..974586e 100644
--- a/src/xbs/Makefile
+++ b/src/xbs/Makefile
@@ -1,2 +1,5 @@
+include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
+include $(topsrcdir)/automake.head.mk
pkgconfdir = $(sysconfdir)/xbs
-include ../../common.mk
+
+include $(topsrcdir)/automake.tail.mk