summaryrefslogtreecommitdiff
path: root/src/xbs/xbs
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@sbcglobal.net>2015-05-24 00:21:00 -0600
committerLuke Shumaker <lukeshu@sbcglobal.net>2015-05-24 00:21:00 -0600
commitfc42feeca49aa42acc28e7a4bd3e43347139b1a5 (patch)
treee1a0abad9b2f3944d73b0a6918008c99f8afd00b /src/xbs/xbs
parent8944f2a0f5f3ba9685f99edf376dd36e688f4ec8 (diff)
Add comments to XBS stuff so that I can understand it drunk.
Or really at all having not had memory of writing it, as most of that was about a year ago and I didn't write any comments and barely any documentation. But it's funnier if I mention that I've had a couple drinks.
Diffstat (limited to 'src/xbs/xbs')
-rwxr-xr-xsrc/xbs/xbs4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/xbs/xbs b/src/xbs/xbs
index 131dee9..8bd3bdf 100755
--- a/src/xbs/xbs
+++ b/src/xbs/xbs
@@ -70,6 +70,10 @@ usage() {
status() {
if [[ ! -f PKGBUILD ]]; then
error 'PKGBUILD not found'
+ # Though in this file in general it doesn't matter, in
+ # this case it does: Using "exit" instead of "return"
+ # is imporant because it prevents flow returning to
+ # release-client.
exit 1
fi
"$HELPER" status "$@"