summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-03-27 19:44:34 -0400
committerLuke Shumaker <lukeshu@lukeshu.com>2018-03-27 21:27:19 -0400
commit086df91f23d1f3486725353ffe1630da8f9c8f5c (patch)
treec583bb8b5ffcfd915b02a44ef9799bd47f2bbbc5 /src
parent36f875645e36bf1ff015cc7d3441de2e1714b6fc (diff)
Makefile: Use files.groups instead of nested.subdirs to split the package
Diffstat (limited to 'src')
-rw-r--r--src/Makefile14
-rw-r--r--src/chroot-tools/Makefile2
-rw-r--r--src/devtools/Makefile2
-rw-r--r--src/gitget/Makefile2
-rw-r--r--src/lib/Makefile2
-rw-r--r--src/xbs-abs/Makefile5
-rw-r--r--src/xbs-abslibre/Makefile1
-rw-r--r--src/xbs/Makefile1
8 files changed, 21 insertions, 8 deletions
diff --git a/src/Makefile b/src/Makefile
index 2ba9534..e148732 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -3,9 +3,15 @@ include $(topsrcdir)/build-aux/Makefile.head.mk
pkgconfdir = $(sysconfdir)
-# Because against all common sense, the subdirectories of this
-# directory aren't `nested.subdirs`, gitfiles includes the files in
-# them in `files.src.src`. So, filter-out everything with a slash.
-files.src.src := $(foreach f,$(files.src.src),$(if $(findstring /,$f),, $f ))
+nested.subdirs += abslibre-tools
+nested.subdirs += chroot-tools
+nested.subdirs += devtools
+nested.subdirs += gitget
+nested.subdirs += lib
+nested.subdirs += librefetch
+nested.subdirs += toru
+nested.subdirs += xbs
+nested.subdirs += xbs-abs
+nested.subdirs += xbs-abslibre
include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index 412ebb5..de79819 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -9,7 +9,7 @@ libretools.out.bins = librechroot libremakepkg
libretools.out.libexecs = arch-nspawn chcleanup distcc-tool indent mkarchroot
libretools.out.libs = $(libretools.src.sh) makechrootpkg.sh
files.out.int += chcleanup.lib
-files.sys.all += $(bindir)/chcleanup # not in libretools.out.bins because explicit rule
+files.sys.libretools += $(bindir)/chcleanup # not in libretools.out.bins because explicit rule
$(srcdir)/makechrootpkg.sh.in: $(srcdir)/makechrootpkg.in
sed -e '1s^.*^#!/hint/bash -euE^' -e '/^\s*main "$$@"\s*$$/d' < $< > $@
diff --git a/src/devtools/Makefile b/src/devtools/Makefile
index 4b7af11..f904406 100644
--- a/src/devtools/Makefile
+++ b/src/devtools/Makefile
@@ -3,7 +3,7 @@ include $(topsrcdir)/build-aux/Makefile.head.mk
libretools.out.bins = checkpkg find-libdeps finddeps lddd
libretools.src.devtools = $(addsuffix .in,$(libretools.out.bins))
-files.sys.all += $(bindir)/find-libprovides
+files.sys.libretools += $(bindir)/find-libprovides
$(DESTDIR)$(bindir)/find-libprovides:
$(MKDIR_P) $(@D)
diff --git a/src/gitget/Makefile b/src/gitget/Makefile
index a1b7765..a846b09 100644
--- a/src/gitget/Makefile
+++ b/src/gitget/Makefile
@@ -1,4 +1,6 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+libretools.pkg = gitget
+
include $(topsrcdir)/build-aux/Makefile.tail.mk
diff --git a/src/lib/Makefile b/src/lib/Makefile
index 515f856..1871e19 100644
--- a/src/lib/Makefile
+++ b/src/lib/Makefile
@@ -1,6 +1,8 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+libretools.pkg = librelib
+
libretools.src.devtools = common.sh.in archroot.sh.in
libretools.out.libs += common.sh archroot.sh conf.sh
diff --git a/src/xbs-abs/Makefile b/src/xbs-abs/Makefile
index c2d6bc9..907b3d0 100644
--- a/src/xbs-abs/Makefile
+++ b/src/xbs-abs/Makefile
@@ -1,6 +1,7 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+libretools.pkg = xbs
pkgconfdir = $(sysconfdir)/xbs
pkglibexecdir = $(libexecdir)/xbs
@@ -13,8 +14,8 @@ libretools.out.bins =
libretools.out.libexecs = helper-abs
libretools.out.libs = valid-tags.sh
-files.out.all += $(_helpers)
-files.sys.all += $(addprefix $(pkglibexecdir)/helper-abs.d/,$(_helpers))
+files.out.xbs += $(_helpers)
+files.sys.xbs += $(addprefix $(pkglibexecdir)/helper-abs.d/,$(_helpers))
$(outdir)/commitpkg: $(srcdir)/commitpkg.in
@echo "OUT $@"
diff --git a/src/xbs-abslibre/Makefile b/src/xbs-abslibre/Makefile
index a86b958..068e6e4 100644
--- a/src/xbs-abslibre/Makefile
+++ b/src/xbs-abslibre/Makefile
@@ -1,6 +1,7 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+libretools.pkg = xbs
pkglibexecdir = $(libexecdir)/xbs
libretools.out.bins =
diff --git a/src/xbs/Makefile b/src/xbs/Makefile
index bc9f4c8..6a39658 100644
--- a/src/xbs/Makefile
+++ b/src/xbs/Makefile
@@ -1,6 +1,7 @@
include $(dir $(lastword $(MAKEFILE_LIST)))/../../config.mk
include $(topsrcdir)/build-aux/Makefile.head.mk
+libretools.pkg = xbs
pkgconfdir = $(sysconfdir)/xbs
include $(topsrcdir)/build-aux/Makefile.tail.mk