summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <lukeshu@lukeshu.com>2018-01-03 12:17:09 -0500
committerLuke Shumaker <lukeshu@lukeshu.com>2018-01-03 13:00:32 -0500
commitb8c5c50d5eddd2346e579184305ecfb61d5660a8 (patch)
tree426020576ff7cf3044420752d0e24528e2ea4f38 /src
parent4bd0f69b5e5889158ccc13c64551f6d42da4c3bd (diff)
update for new devtools
Diffstat (limited to 'src')
-rw-r--r--src/chroot-tools/Makefile4
-rwxr-xr-xsrc/chroot-tools/chcleanup.lib.gen8
-rwxr-xr-xsrc/chroot-tools/libremakepkg1
3 files changed, 11 insertions, 2 deletions
diff --git a/src/chroot-tools/Makefile b/src/chroot-tools/Makefile
index c39b4f5..e3274e0 100644
--- a/src/chroot-tools/Makefile
+++ b/src/chroot-tools/Makefile
@@ -14,8 +14,8 @@ $(srcdir)/makechrootpkg.sh.in: $(srcdir)/makechrootpkg.in
$(outdir)/chcleanup: $(srcdir)/chcleanup.in $(outdir)/chcleanup.lib
m4 -I$(@D) -P $< | $(libretools.edit) | install -m755 /dev/stdin $@
-$(outdir)/chcleanup.lib: $(call at.path,$(topoutdir)/src/lib/common.sh) $(outdir)/Makefile
- bash -c '. $<; declare -f _l plain msg msg2 error' > $@
+$(outdir)/chcleanup.lib: $(srcdir)/chcleanup.lib.gen $(call at.path,$(topoutdir)/src/lib/common.sh)
+ $(abspath $^) > $@
$(outdir)/distcc-tool.pot: LIBREXGETTEXT_FLAGS+=--simple=errusage
diff --git a/src/chroot-tools/chcleanup.lib.gen b/src/chroot-tools/chcleanup.lib.gen
new file mode 100755
index 0000000..71dc327
--- /dev/null
+++ b/src/chroot-tools/chcleanup.lib.gen
@@ -0,0 +1,8 @@
+#!/usr/bin/env bash
+set -e
+
+commonsh=$1
+
+echo '. /usr/share/makepkg/util.sh'
+. "$commonsh"; declare -f _l _p
+sed -n '/^eval/,/^\S/p' "$commonsh"
diff --git a/src/chroot-tools/libremakepkg b/src/chroot-tools/libremakepkg
index 21f5619..d8d935c 100755
--- a/src/chroot-tools/libremakepkg
+++ b/src/chroot-tools/libremakepkg
@@ -146,6 +146,7 @@ usage() {
bullet 'create a `builduser` with the same numeric UID as the
invoking $SUDO_USER.'
bullet 'let this `builduser` call `sudo pacman` without a password.'
+ bullet 'set `keyserver-options` in `~builduser/.gnupg/gpg.conf`'
bullet "copy the user's GnuPG pubring to be the \`builduser\`'s pubring"
bullet 'add a pacman repositoriy of locally built packages'
echo