summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2012-12-08 15:47:37 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2012-12-09 14:20:48 -0500
commit9728388043af86fefee64336c584f5132273c9bc (patch)
tree1b334c07c9a07a13a17e75f4587a94cc08e0def6 /src
parent8d3c769a7133f8e021eb86c296eb415c3356c26a (diff)
make the messages while waiting for a chroot lock more helpful
Diffstat (limited to 'src')
-rwxr-xr-xsrc/chroot-tools/librechroot3
-rwxr-xr-xsrc/chroot-tools/librechroot.gpl23
-rwxr-xr-xsrc/chroot-tools/libremakepkg3
3 files changed, 6 insertions, 3 deletions
diff --git a/src/chroot-tools/librechroot b/src/chroot-tools/librechroot
index cacdfcd..89fb644 100755
--- a/src/chroot-tools/librechroot
+++ b/src/chroot-tools/librechroot
@@ -112,7 +112,8 @@ main() {
# Keep this lock as long as we are running
# Note that '9' is the same FD number as in (mk)archroot
- lock_open_write 9 "$copydir" "Locking chroot copy '$CHROOTCOPY'"
+ lock_open_write 9 "$copydir" \
+ "Waiting for existing lock on \`$copydir' to be released"
if [[ ! -d $rootdir ]]; then
libremkchroot "$CHROOT"
diff --git a/src/chroot-tools/librechroot.gpl2 b/src/chroot-tools/librechroot.gpl2
index b6112a2..1b5d90a 100755
--- a/src/chroot-tools/librechroot.gpl2
+++ b/src/chroot-tools/librechroot.gpl2
@@ -19,7 +19,8 @@ sync() {
exit 1
fi
- lock_open_read 8 "$rootdir" "Locking clean chroot"
+ lock_open_read 8 "$rootdir" \
+ "Waiting for existing lock on \`$rootdir' to be released"
stat_busy 'Creating clean working copy'
local use_rsync=false
diff --git a/src/chroot-tools/libremakepkg b/src/chroot-tools/libremakepkg
index 15f5822..2901b0d 100755
--- a/src/chroot-tools/libremakepkg
+++ b/src/chroot-tools/libremakepkg
@@ -181,7 +181,8 @@ main() {
# OK, we're starting now ###############################################
- lock_open_write 9 "$copydir" "Locking chroot '$CHROOTCOPY'"
+ lock_open_write 9 "$copydir" \
+ "Waiting for existing lock on \`$copydir' to be released"
# Set target CARCH as it might be used within the PKGBUILD to select
# correct sources