summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorLuke Shumaker <LukeShu@sbcglobal.net>2014-01-03 22:22:01 -0500
committerLuke Shumaker <LukeShu@sbcglobal.net>2014-01-03 22:29:36 -0500
commit048ae6172b791ab9f5ae7cce022ba9f6d39dac18 (patch)
tree6a723fba2c407ecbf87acb3505301652cc165dfb /src
parent58e2a9cd5aa9a4eb80f8da675685f62aca128eb3 (diff)
touch up misc qouting
Diffstat (limited to 'src')
-rwxr-xr-xsrc/fullpkg/fullpkg-find4
-rwxr-xr-xsrc/treepkg2
2 files changed, 3 insertions, 3 deletions
diff --git a/src/fullpkg/fullpkg-find b/src/fullpkg/fullpkg-find
index a96bc8a..2a5fc44 100755
--- a/src/fullpkg/fullpkg-find
+++ b/src/fullpkg/fullpkg-find
@@ -51,7 +51,7 @@
# Get repo name. Asumes ${ABSROOT}/repo/package/PKGBUILD
guess_repo() {
- basename $(dirname $(pwd))
+ basename "$(dirname "$(pwd)")"
}
# This function is stolen from makechrootpkg.
@@ -139,7 +139,7 @@ find_deps() {
pushd "${pkgdir}" > /dev/null
# runs itself on dep's PKGBUILD dir
- $0 -l ${next_level} ${build_dir} || return $?
+ "$0" -l "${next_level}" "${build_dir}" || return $?
popd > /dev/null
fi
diff --git a/src/treepkg b/src/treepkg
index e509dac..8879e54 100755
--- a/src/treepkg
+++ b/src/treepkg
@@ -22,7 +22,7 @@ load_files libretools
check_vars libretools HOOKPREBUILD FULLBUILDCMD HOOKLOCALRELEASE || exit 1
load_files makepkg
-term_title "$(basename $0)"
+term_title "${0##*/}"
# End inmediately but print an useful message
trap_exit() {